Jim's right about Builder not being a problem, the other one is the same
issue we've been discussing with msvcr80-ruby.dll problems. Try uninstalling
and reinstalling win32-api to get the right version. If that doesn't work,
force the platform:

gem uninstall win32-api
gem install win32-api --platform=x86-win32-60


Charley Baker
blog: http://charleybakersblog.blogspot.com/
Lead Developer, Watir, http://wtr.rubyforge.org
QA Architect, Gap Inc Direct


On Tue, Feb 24, 2009 at 9:42 AM, AR <reed.a...@gmail.com> wrote:

>
> Thanks Jim - I guess that leaves me with no leads.  I attempted the
> install again on another VM with the same 14001 error.  Google is
> especially dry on this topic - has no one seen this before?
>
> Adam
>
> On Feb 24, 10:34 am, Jim Matthews <jim_m...@swbell.net> wrote:
> > That error has been around a long time and only concerns the
> > documentation for builder.  I has no effect on the way it runs.
> >
> > Jim
> >
> > On Feb 24, 10:20 am, AR <reed.a...@gmail.com> wrote:
> >
> > > While viewing the watir installation again, I do get one error, but it
> > > seems to be fairly innocuous:
> >
> > > ERROR:  While generating documentation for builder-2.1.2
> > > ... MESSAGE:   Unhandled special: Special: type=17, text="<!-- HI -->"
> > > ... RDOC args: --ri --op C:/Ruby/lib/ruby/gems/1.8/doc/builder-2.1.2/
> > > ri --title
> > > Builder -- Easy XML Building --main README --line-numbers --quiet lib
> > > CHANGES Ra
> > > kefile README doc/releases/builder-1.2.4.rdoc doc/releases/
> > > builder-2.0.0.rdoc do
> > > c/releases/builder-2.1.1.rdoc
> > > (continuing with the rest of the installation)
> >
> > > On Feb 24, 9:24 am, AR <reed.a...@gmail.com> wrote:
> >
> > > > I'm getting this strange error after our Ops team built us some new
> > > > testing VMs.  I installed Ruby and Watir, and am getting the same
> > > > error for anything that includes Watir.  I can go into IRB and do
> Ruby
> > > > all day, but as soon as I enter "ie = Watir::IE.new", I get the
> > > > following error.  Has anyone else seen this?
> >
> > > > I have reinstalled Ruby and Watir.  IE7 is installed.  All windows
> > > > updates have been installed.
> >
> > > > OS: Windows 2k3 Server RC2
> > > > RUBY: 1.8.6 (2008-08-11 patchlevel 287) [i386-mswin32]
> > > > WATIR: (installed from gem, crashes when I try to run any watir-
> > > > related command including VERSION)
> >
> > > > irb(main):006:0> ie = Watir::IE.new
> > > > LoadError: 14001: This application has failed to start because the
> > > > application c
> > > > onfiguration is incorrect. Reinstalling the application may fix this
> > > > problem.
> > > > - C:/Ruby/lib/ruby/gems/1.8/gems/win32-api-1.4.0-x86-mswin32-80/lib/
> > > > win32/api.so
> >
> > > >         from C:/Ruby/lib/ruby/gems/1.8/gems/win32-api-1.4.0-x86-
> > > > mswin32-80/lib/w
> > > > in32/api.so
> > > >         from
> C:/Ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:
> > > > 31:in `re
> > > > quire'
> > > >         from C:/Ruby/lib/ruby/gems/1.8/gems/windows-api-0.3.0/lib/
> > > > windows/api.rb
> > > > :1
> > > >         from
> C:/Ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:
> > > > 31:in `ge
> > > > m_original_require'
> > > >         from
> C:/Ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:
> > > > 31:in `re
> > > > quire'
> > > >         from C:/Ruby/lib/ruby/gems/1.8/gems/windows-pr-0.9.3/lib/
> > > > windows/error.r
> > > > b:12
> > > >         from
> C:/Ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:
> > > > 31:in `ge
> > > > m_original_require'
> > > >         from
> C:/Ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:
> > > > 31:in `re
> > > > quire'
> > > >         from C:/Ruby/lib/ruby/gems/1.8/gems/win32-process-0.5.9/lib/
> > > > win32/proces
> > > > s.rb:1
> > > >         from
> C:/Ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:
> > > > 31:in `ge
> > > > m_original_require'
> > > >         from
> C:/Ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:
> > > > 31:in `re
> > > > quire'
> > > >         from C:/Ruby/lib/ruby/gems/1.8/gems/watir-1.6.2/lib/watir/ie-
> > > > process.rb:
> > > > 1
> > > >         from
> C:/Ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:
> > > > 31:in `ge
> > > > m_original_require'
> > > >         from
> C:/Ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:
> > > > 31:in `re
> > > > quire'
> > > >         from C:/Ruby/lib/ruby/gems/1.8/gems/watir-1.6.2/lib/watir/
> > > > ie.rb:45
> > > >         from (irb):6
> > > > irb(main):007:0>
> >
>

--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"Watir General" group.
To post to this group, send email to watir-general@googlegroups.com
Before posting, please read the following guidelines: 
http://wiki.openqa.org/display/WTR/Support
To unsubscribe from this group, send email to 
watir-general-unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/watir-general
-~----------~----~----~----~------~----~------~--~---

Reply via email to