have u tried pointing to the frame and then walking down the dom?

eg: ie.frame(:name, 'xxx').button(:id, 'asdsa').click

On Mar 5, 1:27 pm, James <jgcpal...@gmail.com> wrote:
> I'm just getting into Watir and finding I can do all sorts of great
> things with it.  However, I can't seem to get it to find a button
> within an iframe.  I can find radio buttons in iframes, but not
> regular buttons.
> This happens even on the "official" examples - for instance the
> "Automating Gmail with Watir" example, if I run it, I get this error
> when it tries to click the "Send" button:
>   1) Error:
> test_gmaildemo(GmailDemo):
> Watir::Exception::UnknownObjectException: Unable to locate element,
> using :text,
>  "Send"
>     c:/ruby/lib/ruby/gems/1.8/gems/watir-1.6.2/lib/watir/element.rb:
> 52:in `asser
> t_exists'
>     c:/ruby/lib/ruby/gems/1.8/gems/watir-1.6.2/lib/watir/element.rb:
> 284:in `enab
> led?'
>     c:/ruby/lib/ruby/gems/1.8/gems/watir-1.6.2/lib/watir/element.rb:
> 56:in `asser
> t_enabled'
>     c:/ruby/lib/ruby/gems/1.8/gems/watir-1.6.2/lib/watir/element.rb:
> 229:in `clic
> k!'
>     c:/ruby/lib/ruby/gems/1.8/gems/watir-1.6.2/lib/watir/element.rb:
> 215:in `clic
> k'
>     c:/rubyfiles/googletest.rb:28:in `test_gmaildemo'
> 1 tests, 0 assertions, 0 failures, 1 errors
You received this message because you are subscribed to the Google Groups 
"Watir General" group.
To post to this group, send email to watir-general@googlegroups.com
Before posting, please read the following guidelines: 
To unsubscribe from this group, send email to 
For more options, visit this group at 

Reply via email to