Ok, so going with option 1.
Just to be safe...

[Dennis ide...@t60 C:\]$ gem uninstall win32-api

You have requested to uninstall the gem:
        win32-api-1.4.0-x86-mswin32-60
windows-api-0.2.4 depends on [win32-api (>= 1.0.5)]
windows-api-0.3.0 depends on [win32-api (>= 1.3.0)]
windows-pr-0.9.3 depends on [win32-api (>= 1.2.0)]
If you remove this gems, one or more dependencies will not be met.
Continue with Uninstall? [Yn]

So go ahead and press yes?
By the way, thanks for the help.

On Mar 9, 12:53 am, Bret Pettichord <b...@pettichord.com> wrote:
> i researched this more yesterday. i think either of these will work.
>
> 1. use ruby 186-27 RC 2. after installing watir, the wrong version of
> win32-api might be installed. but it isn't needed and can be uninstalled
> and everything should work fine.
>
> or
>
> 2. manually download the correct win32-api gem and install it using the
> --local switch.
>
> bret
>
> Dennis I. wrote:
> > If anyone has found a real solution to this problem, can you please
> > post it?
>
> > On Mar 7, 6:16 pm, Bret Pettichord <b...@pettichord.com> wrote:
>
> >> My experments have shown that
> >>  1. specifying platform for gem install does not always work (it
> >> sometimes works!)
> >>  2. the 80 version of the file is still on the gem server even if it
> >> isn't on the download page on rubyforge
>
> >> Charley Baker wrote:
>
> >>> The command is wrong:
>
> >>> gem install win32-api --platform=x86-mswin32-60
>
> >>> Daniel's actually removed the 80 version of the file until we get the
> >>> rubygems/hoe situation resolved, so right now you don't have to
> >>> specify this.
>
> >>> Charley Baker
> >>> blog:http://blog.charleybaker.org/
> >>> Lead Developer, Watir,http://wtr.rubyforge.org
> >>> QA Architect, Gap Inc Direct
>
> >>> On Fri, Mar 6, 2009 at 9:09 PM, Dennis I. <ideler.den...@gmail.com
> >>> <mailto:ideler.den...@gmail.com>> wrote:
>
> >>>     C:\Users\Dennis>win32-api gem install - platform = x86 -mswin32-60
> >>>     'win32-api' is not recognized as an internal or external command,
> >>>     operable program or batch file.
>
> >>>     Do I need to specify a PATH? If so, where to?
>
> >>>     I installed watir and ruby at work with no problem.
> >>>     Trying to install them on my own computer now but this error is
> >>>     driving me nuts.
>
> >>>     Additional information:
> >>>     >ruby -v
> >>>     ruby 1.8.6 (2008-08-11 patchlevel 287) [i386-mswin32]
>
> >>>     >gem -v
> >>>     1.3.1
>
> >>>     I installed ruby with the one-click install application.
> >>>     Running Windows Vista on this computer.
>
> >>>     On Feb 24, 4:12 pm, Henry <henrytej...@gmail.com
> >>>     <mailto:henrytej...@gmail.com>> wrote:
> >>>     > Problem solved in this way as indicated by a previous post:
>
> >>>     > gem uninstall win32-api
> >>>     > win32-api gem install - platform = x86 -mswin32-60
>
> >>>     > Excuse my English
> >>>     > Thank you very much.
>
> >>>     > On 24 feb, 17:09, Charley Baker <charley.ba...@gmail.com
> >>>     <mailto:charley.ba...@gmail.com>> wrote:
>
> >>>     > > Look through the mails for the past couple of days, there are
> >>>     a lots of
> >>>     > > posts on this.
>
> >>>     > > Charley Baker
> >>>     > > blog:http://charleybakersblog.blogspot.com/
> >>>     > > Lead Developer, Watir,http://wtr.rubyforge.org
> >>>     > > QA Architect, Gap Inc Direct
>
> >>>     > > On Tue, Feb 24, 2009 at 11:45 AM, Henry <henrytej...@gmail.com
> >>>     <mailto:henrytej...@gmail.com>> wrote:
>
> >>>     > > > I can not solve the following problem:
> >>>     > > > "Error uncertain that the application was not found msvcr80-
> >>>     > > > ruby18.dll"
> >>>     > > > This error occurred in 4 pc. And reinstall several times but
> >>>     continued
> >>>     > > > Watir and Ruby does not work.
> >>>     > > > I appreciate your help
> >>>     > > > Henry
>
> >>>     > > > On 18 feb, 13:31, Bret Pettichord <b...@pettichord.com
> >>>     <mailto:b...@pettichord.com>> wrote:
> >>>     > > > > some one else reported it recently. it seemed to be caused
> >>>     by the fact
> >>>     > > > > that they had visual studio installed. please see the
> >>>     archives for
> >>>     > > > details.
>
> >>>     > > > > bret
>
> >>>     > > > > al3kc wrote:
> >>>     > > > > > When I try to require watir and run this file I got the
> >>>     error
>
> >>>     > > > > > This application failed to start because
> >>>     msvcr80-ruby18.dllwas not
> >>>     > > > > > found. Re-installing the application may fix this problem.
>
> >>>     > > > > > I reinstalled ruby and watir gem two times but still
> >>>     have this error.
> >>>     > > > > > Windows-pr gem is installed too.
>
> >>>     > > > > > Did anybody saw this error before?
--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"Watir General" group.
To post to this group, send email to watir-general@googlegroups.com
Before posting, please read the following guidelines: 
http://wiki.openqa.org/display/WTR/Support
To unsubscribe from this group, send email to 
watir-general-unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/watir-general
-~----------~----~----~----~------~----~------~--~---

Reply via email to