Thanks for the suggestion, but still getting an error. It seems there
may be something wrong with my environment or system or some gem
package problem.  I don't think its a code problem.

I tried:

require "watir"
require 'watir/browser'
Watir::Browser.default = 'ie'
b = Watir::Browser.new

and get this error:

C:/Ruby1/lib/ruby/gems/1.8/gems/commonwatir-1.6.2/lib/watir/browser.rb:
75:in `klass': (eval):1:in `klass': uninitialized constant Watir::IE
(NameError)
        from C:/Ruby1/lib/ruby/gems/1.8/gems/commonwatir-1.6.2/lib/
watir/browser.rb:65:in `eval'
        from C:/Ruby1/lib/ruby/gems/1.8/gems/commonwatir-1.6.2/lib/
watir/browser.rb:75:in `klass'
        from C:/Ruby1/lib/ruby/gems/1.8/gems/commonwatir-1.6.2/lib/
watir/browser.rb:65:in `new'
        from javascriptTest.rb:4

when i replace 'ie' with 'firefox' everything works fine, but again in
a Firefox browser, not an IE one.

On Mar 13, 10:56 am, John Fitisoff <jfitis...@yahoo.com> wrote:
> require 'watir/browser'
> Watir::Browser.default = 'ie'
> b = Watir::Browser.new
>
> --- On Fri, 3/13/09, bert <tumbaol...@yahoo.com> wrote:
>
> > From: bert <tumbaol...@yahoo.com>
> > Subject: [wtr-general] Error when trying to open Watir::IE browser
> > To: "Watir General" <watir-general@googlegroups.com>
> > Date: Friday, March 13, 2009, 8:15 AM
>
> > Hi,  Im a newbie to Watir and Ruby.  My problem
> > is that when I try to
> > open an IE browser, it fails.  Firefox works.  I
> > would like to be able
> > to use both browsers at will.  I verified that I
> > physically have a
> > file called ie.rb in the following directory:
> > C:\Ruby1\lib\ruby\gems
> > \1.8\gems\watir-1.6.2\lib\watir
> > Incidentally, if I have: require "watir_simple"
> > I get the same no such file to load error.  But again,
> > watir_simple.rb
> > exits in the path above.
>
> > Thank you for your help in advance!
>
> > CODE:
>
> > require "watir"
>
> > ie=Watir::IE.start('http://www.google.com')
>
> > ERROR:
>
> >    javascriptTest.rb:2: no such file to load
> > -- watir/ie
> > (LoadError)
>
> > RubyGems Environment:
> >   - RUBYGEMS VERSION: 1.3.1
> >   - RUBY VERSION: 1.8.6 (2008-08-11 patchlevel 287)
> > [i386-mswin32]
> >   - INSTALLATION DIRECTORY:
> > C:/Ruby1/lib/ruby/gems/1.8
> >   - RUBY EXECUTABLE: C:/Ruby1/bin/ruby.exe
> >   - EXECUTABLE DIRECTORY: C:/Ruby1/bin
> >   - RUBYGEMS PLATFORMS:
> >     - ruby
> >     - x86-mswin32-60
> >   - GEM PATHS:
> >      - C:/Ruby1/lib/ruby/gems/1.8
> >      - C:/Documents and
> > Settings/hurivero/.gem/ruby/1.8
> >   - GEM CONFIGURATION:
> >      - :update_sources => true
> >      - :verbose => true
> >      - :benchmark => false
> >      - :backtrace => false
> >      - :bulk_threshold => 1000
> >   - REMOTE SOURCES:
> >      -http://gems.rubyforge.org/
>
> > *** LOCAL GEMS ***
>
> > activesupport (2.2.2)
> > builder (2.1.2)
> > commonwatir (1.6.2)
> > firewatir (1.6.2)
> > fxri (0.3.6)
> > fxruby (1.6.16)
> > hoe (1.10.0)
> > hpricot (0.6.164)
> > log4r (1.0.5)
> > ptools (1.1.6)
> > rake (0.8.4, 0.8.1)
> > ruby-opengl (0.60.0)
> > rubyforge (1.0.3)
> > s4t-utils (1.0.4)
> > test-unit (2.0.1)
> > user-choices (1.1.6)
> > watir (1.6.2)
> > win32-api (1.2.1, 1.2.0)
> > win32-clipboard (0.4.4)
> > win32-dir (0.3.2)
> > win32-eventlog (0.5.0)
> > win32-file (0.5.5)
> > win32-file-stat (1.3.1)
> > win32-process (0.5.9)
> > win32-sapi (0.1.4)
> > win32-sound (0.4.1)
> > windows-api (0.3.0, 0.2.4)
> > windows-pr (0.9.3)
> > xml-simple (1.0.12)
>
>
--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"Watir General" group.
To post to this group, send email to watir-general@googlegroups.com
Before posting, please read the following guidelines: 
http://wiki.openqa.org/display/WTR/Support
To unsubscribe from this group, send email to 
watir-general-unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/watir-general
-~----------~----~----~----~------~----~------~--~---

Reply via email to