I ran your code and it worked for me.

What Version of ruby did you load?

Type in command prompt
ruby -v


What gems do you have installed?
gem list



-----Original Message-----
From: watir-general@googlegroups.com
[mailto:watir-gene...@googlegroups.com] On Behalf Of
vladimir...@hotmail.com
Sent: Wednesday, March 18, 2009 6:42 PM
To: Watir General
Subject: [wtr-general] Getting 'assert_exists': Unable to locate
element, using :name, "q" (Watir::Exception::UnknownObject...


I was trying to run google_search.rb from tutorial:

require 'watir'

# set a variable
test_site = "http://www.google.com";

# open the IE browser
ie = Watir::IE.new

ie.goto test_site

ie.text_field(:name, "q").set "pickaxe" # "q" is the name of the
search field

Always getting 'assert_exists': Unable to locate element, using :name,
"q" (Watir::Exception::UnknownObjectException...)

Spent already half a day. Nothing works. Please, help.

Thank you very much,
Vladimir




--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"Watir General" group.
To post to this group, send email to watir-general@googlegroups.com
Before posting, please read the following guidelines: 
http://wiki.openqa.org/display/WTR/Support
To unsubscribe from this group, send email to 
watir-general-unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/watir-general
-~----------~----~----~----~------~----~------~--~---

Reply via email to