Let me comment on my own post with an example. I might be having a
Ruby problem and not a Watir problem. Here is what I am trying to do:


require 'watir'

Watir::Browser.default = 'firefox'
browser = Watir::Browser.new

sites = %w("www.google.com" "www.yahoo.com" "www.microsoft.com")

sites.each do

  |url|

  puts "going to website: #{url}"
  browser.goto(url)

  puts "Browser went to:  #{browser.url}"

end




On Mar 26, 10:46 am, Kevin White <ilium...@gmail.com> wrote:
> I'm trying to test that a web application always redirects back to a
> login page if you try to go to one of the application's pages when
> you're not logged in.
>
> First, I do:
>
> browser.goto("http://www.pagethatredirects.com";)
>
> Then, I look at the contents of @browser.url and I get "about: blank",
> which is what my firefox install opens up to.
>
> From what I've read, Watir/firewatir should be waiting until the page
> is loaded before executing the browser.url statement. I'm basing that
> on:http://wiki.openqa.org/display/WTR/How+to+wait+with+Watir
>
> However, that isn't really working the way I expect. Should I be using
> wait_until?
--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"Watir General" group.
To post to this group, send email to watir-general@googlegroups.com
Before posting, please read the following guidelines: 
http://wiki.openqa.org/display/WTR/Support
To unsubscribe from this group, send email to 
watir-general-unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/watir-general
-~----------~----~----~----~------~----~------~--~---

Reply via email to