that error means that watir couldnt find that raidio button. If you post the
html, we might be able to help you more. Are you sure its not ina frame?

Paul

On Sat, Apr 4, 2009 at 3:35 AM, spike <vinaykumarl...@gmail.com> wrote:

>
> Hello,
>
> i'm working on watir  with Internet Explorer, i'm trying to select a
> radio button using the command
>
> ie.radio(:id, "RdUpload").set
>
> its not working for me i'm getting the following error. please suggest
> me a solution to this.
>
> Here is the ERROR code displayed.
>
> irb(main):031:0> ie.radio(:id, "RdUpload").set
> Watir::Exception::UnknownObjectException: Unable to locate element,
> using :id, "
> RdUpload"
>        from D:/Ruby/lib/ruby/gems/1.8/gems/watir-1.6.2/lib/watir/
> element.rb:52:
> in `assert_exists'
>        from D:/Ruby/lib/ruby/gems/1.8/gems/watir-1.6.2/lib/watir/
> element.rb:284
> :in `enabled?'
>        from D:/Ruby/lib/ruby/gems/1.8/gems/watir-1.6.2/lib/watir/
> element.rb:56:
> in `assert_enabled'
>        from D:/Ruby/lib/ruby/gems/1.8/gems/watir-1.6.2/lib/watir/
> input_elements
> .rb:505:in `set'
>        from (irb):31
>
>
>
> thankingyou
>
>
> >
>

--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"Watir General" group.
To post to this group, send email to watir-general@googlegroups.com
Before posting, please read the following guidelines: 
http://wiki.openqa.org/display/WTR/Support
To unsubscribe from this group, send email to 
watir-general-unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/watir-general
-~----------~----~----~----~------~----~------~--~---

Reply via email to