did you installed JSSh XPI with administrator privileges? There are lot of
people who came across this problem with JSSh but was solved once installed
with admin privileges.

- Angrez

On Tue, Jun 30, 2009 at 11:33 AM, aparna <aparna.m...@gmail.com> wrote:

>
> Hi,
>
> I am facing an error when i tried to run watir script on firefox
> 3.0.11. Actually the ruby which i have installed is ruby 1.8.6 26 and
> watir is 1.6.2. Also I have installed firewatir and JSSH (0.9)
> extension. I have changed the settings on firefox like "allowing the
> popups" and "firefox opens a new window instead of new tab when a link
> is clicked".
>
> The platform which i am using is windows vista and my system is a 32
> bit machine.
>
> The following is my error -
>
> >ruby firefox.rb
> c:/ruby/lib/ruby/gems/1.8/gems/firewatir-1.6.2/lib/firewatir/
> firefox.rb:271:in `set_defaults': Unable to connect to machine :
> 127.0.0.1 on port 9997. Make sure that JSSh is properly installed and
> Firefox is running with '-jssh' option
> (Watir::Exception::UnableToStartJSShException)
>        from c:/ruby/lib/ruby/gems/1.8/gems/firewatir-1.6.2/lib/firewatir/
> firefox.rb:161:in `initialize'
>        from c:/ruby/lib/ruby/gems/1.8/gems/commonwatir-1.6.2/lib/watir/
> browser.rb:65:in `new'
>        from c:/ruby/lib/ruby/gems/1.8/gems/commonwatir-1.6.2/lib/watir/
> browser.rb:65:in `new'
>        from firefox.rb:5
> >Exit code: 1
>
> I have uninstalled the whole ruby, reinstalled and then tried running
> the watir script. But still am facing the same issue. Please anyone do
> help me in solving this error.
>
> Thanks & Regards,
> Aparna.
>
> >
>

--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"Watir General" group.
To post to this group, send email to watir-general@googlegroups.com
Before posting, please read the following guidelines: 
http://wiki.openqa.org/display/WTR/Support
To unsubscribe from this group, send email to 
watir-general-unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/watir-general
-~----------~----~----~----~------~----~------~--~---

Reply via email to