There was also a warning on the page that said that you could not run 
the unit tests from a gem installation.

Since this meant that step 4 would never work, however, i decided to 
remove step 4 (and the warning) from the page.

Bret

rrash586 wrote:
> Hi All,
>
> I want to use Firefox browser for testing one of the webpplication.
> But after following all the steps mentioned on link mentioned below
>
> http://wiki.openqa.org/display/WTR/FireWatir+Installation#FireWatirInstallation-4%29%28Optional%29RunFireWatirunittests
>
> 1) Install the FireWatir Gem
> 2) Install the JSSH Firefox Extension
> 3) Ensure Firefox settings are correct
> 4) (Optional) Run FireWatir unit tests
>
> but when i execute the 4 th steps i am getting following error
>
> c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
> `gem_original_require': no such file to load -- unittests/setup/lib
> (LoadError)
>       from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
> `require'
>       from C:/ruby/lib/ruby/gems/1.8/gems/firewatir-1.6.2/unittests/
> setup.rb:15
>       from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
> `gem_original_require'
>       from c:/ruby/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:31:in
> `require'
>       from mozilla_all_tests.rb:3
>
>
> I am not getting what is the exact error.
>
> I tried the sample script mentioned in one of the jssh post which are
>
> 1.require 'watir'
> Watir.options[:browser]='firefox'
> ff=Watir::Browser.new
> ff.goto ('www.google.com')
>
> 2.
> require 'firewatir'
> system("C:\\Program Files\\Mozilla Firefox\\firefox.exe -jssh")
> sleep(5)
> $ie = FireWatir::Firefox.new
> $ie.goto("google.com")
> puts $ie.title
>
> 3.
> require 'firewatir'
> system("C:\\Program Files\\Mozilla Firefox\\firefox.exe -jssh")
> sleep(5)
> $ie = FireWatir::Firefox.attach(:title,"Google")
> $ie.goto("google.com")
> puts $ie.title
>
>
> in all the above three cases firefox browser opened but the execution
> of the script hanged and script not navigate to proper url i.e to
> www.google.com
>
> I am using Firefox 3.0.10 and FireWatir 1.6.2
>
> Please tell me if anything or any steps i am missing or what the exact
> problem and how can i overcome the same .
>
> Thanks in advance
> >
>   


-- 
Bret Pettichord
Lead Developer, Watir, www.watir.com
Blog, www.io.com/~wazmo/blog
Twitter, www.twitter.com/bpettichord


--~--~---------~--~----~------------~-------~--~----~
You received this message because you are subscribed to the Google Groups 
"Watir General" group.
To post to this group, send email to watir-general@googlegroups.com
Before posting, please read the following guidelines: 
http://wiki.openqa.org/display/WTR/Support
To unsubscribe from this group, send email to 
watir-general-unsubscr...@googlegroups.com
For more options, visit this group at 
http://groups.google.com/group/watir-general
-~----------~----~----~----~------~----~------~--~---

Reply via email to