Please follow the instructions here for using FireWatir:
http://wiki.openqa.org/display/WTR/FireWatir#FireWatir-Installation

On Tue, Apr 6, 2010 at 3:13 PM, Yuping Zhong <littlezhong...@gmail.com>wrote:

> Dear All,
>
> I already install the firewatir and jssh-3.6-OSX. But it is fail to use the
> firefox in Mac.It display the strange error:
> RuntimeError: Firefox is running without -jssh
>
>  But I already install the jssh.
>
> ====
>
> Here the steps:
>
> irb(main):001:0> require "rubygems"
> => true
> irb(main):002:0> require "firewatir"
> => true
> irb(main):003:0> Watir::Browser.default = "firefox"
> => "firefox"
> irb(main):004:0> ff = Watir::Browser.start("http://www.google.com";)
> RuntimeError: Firefox is running without -jssh
> from
> /usr/local/lib/ruby/gems/1.8/gems/firewatir-1.6.5/lib/firewatir/firefox.rb:125:in
> `initialize'
>  from
> /usr/local/lib/ruby/gems/1.8/gems/firewatir-1.6.5/lib/firewatir/firefox.rb:163:in
> `new'
> from
> /usr/local/lib/ruby/gems/1.8/gems/firewatir-1.6.5/lib/firewatir/firefox.rb:163:in
> `start'
>  from
> /usr/local/lib/ruby/gems/1.8/gems/commonwatir-1.6.5/lib/watir/browser.rb:71:in
> `start'
>
>
> Any idea?
>
> Thanks!
>
> -Zhong
>
> --
> Before posting, please read http://watir.com/support. In short: search
> before you ask, be nice.
>
> You received this message because you are subscribed to
> http://groups.google.com/group/watir-general
> To post: watir-general@googlegroups.com
>

-- 
Before posting, please read http://watir.com/support. In short: search before 
you ask, be nice.

You received this message because you are subscribed to 
http://groups.google.com/group/watir-general
To post: watir-general@googlegroups.com

To unsubscribe, reply using "remove me" as the subject.

Reply via email to