Why not call it Z instead of TWIST?

I'm pretty certain that is a common term for this movement, and that "twist" is a rather strange term ("roll" is used more). And Z has the advantage that it also implies that counter-clockwise is positive.

On 12/08/2014 09:59 AM, Jason Gerecke wrote:

--- a/src/libinput.h
+++ b/src/libinput.h
@@ -277,7 +277,8 @@ enum libinput_tablet_axis {
        LIBINPUT_TABLET_AXIS_PRESSURE = 3,
        LIBINPUT_TABLET_AXIS_TILT_X = 4,
        LIBINPUT_TABLET_AXIS_TILT_Y = 5,
-       LIBINPUT_TABLET_AXIS_CNT = LIBINPUT_TABLET_AXIS_TILT_Y + 1
+       LIBINPUT_TABLET_AXIS_TWIST = 6,
+       LIBINPUT_TABLET_AXIS_CNT = LIBINPUT_TABLET_AXIS_TWIST + 1
  };
_______________________________________________
wayland-devel mailing list
wayland-devel@lists.freedesktop.org
http://lists.freedesktop.org/mailman/listinfo/wayland-devel

Reply via email to