On Tue, 3 Dec 2019 12:26:59 +0530
"Devashish Tiwari" <devash...@cdot.in> wrote:

> Hello,
> 
> It seems like Weston with Xwayland is still not working for me.
> Despite of the positive xserver-related prints I get in weston.log
> file :
> 

> ---------------
> 
> [02:43:02.573] Loading module '/usr/lib/libweston-2/xwayland.so'
> [02:43:02.587] Registered plugin API 'weston_xwayland_v1' of size 16
> [02:43:02.587] Registered plugin API 'weston_xwayland_surface_v1' of size 8
> [02:43:02.587] xserver listening on display :0
> [02:43:02.587] launching '/usr/libexec/weston-desktop-shell'
> 
> ---------------

> 
> I am not able to run any X-client within weston-terminal. My $DISPLAY
> variable is set to  ":0" by default, but as I run any X-client
> (xclock, xconsole, xhost, xcalc etc.) or any X11 basic sample code I
> get following error:
> 
> Error: Can't open display: :0

Hi,

Weston launches Xwayland on-demand. The log snippet above does not mean
Xwayland was already started, it's just Weston listening on the X11
socket. Check your Weston stdout/stderr after you failed to launch an
X11 app.

You can also 'strace' your X11 app to see if it e.g. doesn't have the
permission to the open the socket for some strange reason.


Thanks,
pq

Attachment: pgpH5IV2RE2Vy.pgp
Description: OpenPGP digital signature

_______________________________________________
wayland-devel mailing list
wayland-devel@lists.freedesktop.org
https://lists.freedesktop.org/mailman/listinfo/wayland-devel

Reply via email to