Branch: refs/heads/main
Home: https://github.com/WebKit/WebKit
Commit: 85db209cf65d735fab78a76c5321a57fef7af0dd
https://github.com/WebKit/WebKit/commit/85db209cf65d735fab78a76c5321a57fef7af0dd
Author: Sammy Gill <[email protected]>
Date: 2026-08-21 (Fri, 21 Aug 2026)
Changed paths:
M Source/WebCore/rendering/GridLanesLayout.cpp
M Source/WebCore/rendering/GridLanesLayout.h
M Source/WebCore/rendering/RenderGrid.cpp
Log Message:
-----------
[Grid Lanes] Remove redundant "Phase" suffix from GridLanesLayout::Phase enum
values.
https://bugs.webkit.org/show_bug.cgi?id=322307
rdar://185544976
Reviewed by Tim Nguyen.
The values of GridLanesLayout::Phase repeated the name of the enum
itself (LayoutPhase, MinContentPhase, MaxContentPhase). Drop the
redundant suffix so the values read as Phase::Layout, Phase::MinContent
and Phase::MaxContent. No change in behavior.
* Source/WebCore/rendering/GridLanesLayout.cpp:
(WebCore::GridLanesLayout::calculateGridLanesIntrinsicLogicalWidth):
(WebCore::GridLanesLayout::insertIntoGridAndLayoutItem):
* Source/WebCore/rendering/GridLanesLayout.h:
* Source/WebCore/rendering/RenderGrid.cpp:
(WebCore::RenderGrid::layoutGridLanes):
(WebCore::RenderGrid::computeIntrinsicLogicalWidths):
Canonical link: https://commits.webkit.org/319631@main
To unsubscribe from these emails, change your notification settings at
https://github.com/WebKit/WebKit/settings/notifications