Branch: refs/heads/main
Home: https://github.com/WebKit/WebKit
Commit: 117c2123daa060fcada4218713a7083116dd29bc
https://github.com/WebKit/WebKit/commit/117c2123daa060fcada4218713a7083116dd29bc
Author: Sammy Gill <[email protected]>
Date: 2026-08-25 (Tue, 25 Aug 2026)
Changed paths:
M LayoutTests/TestExpectations
M
LayoutTests/imported/w3c/web-platform-tests/css/css-cascade/all-prop-initial-xml-expected.txt
A
LayoutTests/imported/w3c/web-platform-tests/css/css-grid/grid-lanes/animation/fit-tolerance-interpolation-expected.txt
A
LayoutTests/imported/w3c/web-platform-tests/css/css-grid/grid-lanes/animation/fit-tolerance-interpolation.html
R
LayoutTests/imported/w3c/web-platform-tests/css/css-grid/grid-lanes/animation/flow-tolerance-interpolation-expected.txt
R
LayoutTests/imported/w3c/web-platform-tests/css/css-grid/grid-lanes/animation/flow-tolerance-interpolation.html
M LayoutTests/platform/glib/TestExpectations
M
LayoutTests/platform/glib/imported/w3c/web-platform-tests/css/css-cascade/all-prop-initial-xml-expected.txt
M LayoutTests/platform/wpe/TestExpectations
M Source/WebCore/Headers.cmake
M Source/WebCore/Sources.txt
M Source/WebCore/WebCore.xcodeproj/project.pbxproj
M Source/WebCore/css/CSSProperties.json
M Source/WebCore/rendering/GridLanesLayout.cpp
M Source/WebCore/style/computed/StyleComputedStyleBase.h
M Source/WebCore/style/computed/data/StyleGridData.cpp
M Source/WebCore/style/computed/data/StyleGridData.h
A Source/WebCore/style/values/grid/StyleFitTolerance.cpp
A Source/WebCore/style/values/grid/StyleFitTolerance.h
R Source/WebCore/style/values/grid/StyleFlowTolerance.cpp
R Source/WebCore/style/values/grid/StyleFlowTolerance.h
M Source/WebInspectorUI/Localizations/en.lproj/localizedStrings.js
M
Source/WebInspectorUI/UserInterface/Views/SpreadsheetCSSStyleDeclarationEditor.css
M
Source/WebInspectorUI/UserInterface/Views/SpreadsheetStyleProperty.js
Log Message:
-----------
[Grid Lanes] Rename flow-tolerance to fit-tolerance
https://bugs.webkit.org/show_bug.cgi?id=321948
rdar://185125327
Reviewed by Alan Baradlay.
The CSSWG resolved to rename the flow-tolerance property to fit-tolerance
(https://github.com/w3c/csswg-drafts/issues/10884), so rename it here, along
with the Style::FlowTolerance value type and the GridData member that stores it.
flow-tolerance is kept as an alias so that content written against the old name
keeps working. This is a temporary measure and will likely be removed at
some point in the future. To help facilitate this process we show a
deprecation warning in the web inspector. When the old name is used the
web inspector will show a warning icon next to the declaration and a
hover will inform the user that the property name is deprecated.
*
Source/WebInspectorUI/UserInterface/Views/SpreadsheetStyleProperty.js:
Rather than creating a generic deprecated alias mechanism I just extend
the logic here to consider the flow-tolerance/fit-tolerance case
directly. I do not expect this type of behavior to become more of a
common occurrence in the future and definitely would not want to
encourage it!
* Source/WebCore/css/CSSProperties.json:
The property definition was sitting in the middle of the inset-* block,
which it has nothing to do with. Move it to the end of the grid family so
it lives next to the other css-grid properties. This is a pure move; the
definition itself is unchanged.
*
LayoutTests/imported/w3c/web-platform-tests/css/css-grid/grid-lanes/animation/flow-tolerance-interpolation.html:
Removed.
*
LayoutTests/imported/w3c/web-platform-tests/css/css-grid/grid-lanes/animation/flow-tolerance-interpolation-expected.txt:
Removed.
*
LayoutTests/imported/w3c/web-platform-tests/css/css-grid/grid-lanes/animation/fit-tolerance-interpolation.html:
Added.
*
LayoutTests/imported/w3c/web-platform-tests/css/css-grid/grid-lanes/animation/fit-tolerance-interpolation-expected.txt:
Added.
The interpolation test has to use the canonical property name rather than
the alias. The Web Animations portion of the interpolation harness hands
the property to Element.animate() in IDL form, and
IDLAttributeNameToAnimationPropertyName() rejects any name that does not
round trip back to itself, so keyframes naming "flowTolerance" are
dropped and the Web Animations subtests all observe the initial value
instead of an animated one. The CSS Transitions and CSS Animations
portions set the property through style.setProperty(), where the alias
resolves normally, which is why only part of the test was affected.
*
LayoutTests/imported/w3c/web-platform-tests/css/css-cascade/all-prop-initial-xml-expected.txt:
*
LayoutTests/platform/glib/imported/w3c/web-platform-tests/css/css-cascade/all-prop-initial-xml-expected.txt:
This test enumerates the computed style property list, which is sorted by
property name and does not include aliases, so the entry is renamed and
also moves out of the "fl" block into the "fi" block.
* LayoutTests/TestExpectations:
* LayoutTests/platform/glib/TestExpectations:
* LayoutTests/platform/wpe/TestExpectations:
Follow the test rename.
Canonical link:
https://flagged.apple.com:443/proxy?t2=DE0G0A7xG4&o=aHR0cHM6Ly9jb21taXRzLndlYmtpdC5vcmcvMzE5Nzk1QG1haW4=&emid=de1391f2-8781-4495-a01e-1ac50b00137e&c=11
To unsubscribe from these emails, change your notification settings at
https://github.com/WebKit/WebKit/settings/notifications