Title: [101046] trunk/Source/WebCore
- Revision
- 101046
- Author
- [email protected]
- Date
- 2011-11-23 00:26:17 -0800 (Wed, 23 Nov 2011)
Log Message
Use new name for pixel config field of GrTextureDesc
https://bugs.webkit.org/show_bug.cgi?id=72543
Patch by Brian Salomon <[email protected]> on 2011-11-23
Reviewed by Stephen White.
Tested by every canvas2d layout test.
* platform/graphics/skia/ImageBufferSkia.cpp:
(WebCore::createAcceleratedCanvas):
Modified Paths
Diff
Modified: trunk/Source/WebCore/ChangeLog (101045 => 101046)
--- trunk/Source/WebCore/ChangeLog 2011-11-23 08:21:18 UTC (rev 101045)
+++ trunk/Source/WebCore/ChangeLog 2011-11-23 08:26:17 UTC (rev 101046)
@@ -1,3 +1,15 @@
+2011-11-23 Brian Salomon <[email protected]>
+
+ Use new name for pixel config field of GrTextureDesc
+ https://bugs.webkit.org/show_bug.cgi?id=72543
+
+ Reviewed by Stephen White.
+
+ Tested by every canvas2d layout test.
+
+ * platform/graphics/skia/ImageBufferSkia.cpp:
+ (WebCore::createAcceleratedCanvas):
+
2011-11-23 Emil A Eklund <[email protected]>
Change remaining scrollTop/Left/Width/Height methods back to int
Modified: trunk/Source/WebCore/platform/graphics/skia/ImageBufferSkia.cpp (101045 => 101046)
--- trunk/Source/WebCore/platform/graphics/skia/ImageBufferSkia.cpp 2011-11-23 08:21:18 UTC (rev 101045)
+++ trunk/Source/WebCore/platform/graphics/skia/ImageBufferSkia.cpp 2011-11-23 08:26:17 UTC (rev 101046)
@@ -79,7 +79,7 @@
desc.fAALevel = kNone_GrAALevel;
desc.fWidth = size.width();
desc.fHeight = size.height();
- desc.fFormat = kRGBA_8888_GrPixelConfig;
+ desc.fConfig = kRGBA_8888_GrPixelConfig;
SkAutoTUnref<GrTexture> texture(gr->createUncachedTexture(desc, 0, 0));
if (!texture.get())
return 0;
_______________________________________________
webkit-changes mailing list
[email protected]
http://lists.webkit.org/mailman/listinfo.cgi/webkit-changes