Title: [242700] trunk/Source/WebCore
- Revision
- 242700
- Author
- [email protected]
- Date
- 2019-03-11 05:58:57 -0700 (Mon, 11 Mar 2019)
Log Message
Rename contentOffsetInCompostingLayer to contentOffsetInCompositingLayer
https://bugs.webkit.org/show_bug.cgi?id=195553
Reviewed by Simon Fraser.
Less composting, more compositing.
* rendering/RenderLayerBacking.cpp:
(WebCore::RenderLayerBacking::updateBackdropFiltersGeometry):
(WebCore::RenderLayerBacking::resetContentsRect):
(WebCore::RenderLayerBacking::updateChildClippingStrategy):
(WebCore::RenderLayerBacking::updateImageContents):
(WebCore::RenderLayerBacking::contentOffsetInCompositingLayer const):
(WebCore::RenderLayerBacking::contentsBox const):
(WebCore::RenderLayerBacking::backgroundBoxForSimpleContainerPainting const):
(WebCore::RenderLayerBacking::contentOffsetInCompostingLayer const): Deleted.
* rendering/RenderLayerBacking.h:
Modified Paths
Diff
Modified: trunk/Source/WebCore/ChangeLog (242699 => 242700)
--- trunk/Source/WebCore/ChangeLog 2019-03-11 06:20:53 UTC (rev 242699)
+++ trunk/Source/WebCore/ChangeLog 2019-03-11 12:58:57 UTC (rev 242700)
@@ -1,3 +1,23 @@
+2019-03-11 Antti Koivisto <[email protected]>
+
+ Rename contentOffsetInCompostingLayer to contentOffsetInCompositingLayer
+ https://bugs.webkit.org/show_bug.cgi?id=195553
+
+ Reviewed by Simon Fraser.
+
+ Less composting, more compositing.
+
+ * rendering/RenderLayerBacking.cpp:
+ (WebCore::RenderLayerBacking::updateBackdropFiltersGeometry):
+ (WebCore::RenderLayerBacking::resetContentsRect):
+ (WebCore::RenderLayerBacking::updateChildClippingStrategy):
+ (WebCore::RenderLayerBacking::updateImageContents):
+ (WebCore::RenderLayerBacking::contentOffsetInCompositingLayer const):
+ (WebCore::RenderLayerBacking::contentsBox const):
+ (WebCore::RenderLayerBacking::backgroundBoxForSimpleContainerPainting const):
+ (WebCore::RenderLayerBacking::contentOffsetInCompostingLayer const): Deleted.
+ * rendering/RenderLayerBacking.h:
+
2019-03-10 Ross Kirsling <[email protected]>
Invalid flags in a RegExp literal should be an early SyntaxError
Modified: trunk/Source/WebCore/rendering/RenderLayerBacking.cpp (242699 => 242700)
--- trunk/Source/WebCore/rendering/RenderLayerBacking.cpp 2019-03-11 06:20:53 UTC (rev 242699)
+++ trunk/Source/WebCore/rendering/RenderLayerBacking.cpp 2019-03-11 12:58:57 UTC (rev 242700)
@@ -533,7 +533,7 @@
LayoutRect boxRect = renderer.borderBoxRect();
if (renderer.hasClip())
boxRect.intersect(renderer.clipRect(LayoutPoint(), nullptr));
- boxRect.move(contentOffsetInCompostingLayer());
+ boxRect.move(contentOffsetInCompositingLayer());
FloatRoundedRect backdropFiltersRect;
if (renderer.style().hasBorderRadius() && !renderer.hasClip())
@@ -1378,7 +1378,7 @@
if (is<RenderBox>(renderer())) {
LayoutRect boxRect(LayoutPoint(), downcast<RenderBox>(renderer()).size());
- boxRect.move(contentOffsetInCompostingLayer());
+ boxRect.move(contentOffsetInCompositingLayer());
FloatRoundedRect contentsClippingRect = renderer().style().getRoundedInnerBorderFor(boxRect).pixelSnappedRoundedRectForPainting(deviceScaleFactor());
m_graphicsLayer->setContentsClippingRect(contentsClippingRect);
}
@@ -1716,7 +1716,7 @@
if (hasClippingLayer() && needsDescendantsClippingLayer) {
if (is<RenderBox>(renderer()) && (renderer().style().clipPath() || renderer().style().hasBorderRadius())) {
LayoutRect boxRect(LayoutPoint(), downcast<RenderBox>(renderer()).size());
- boxRect.move(contentOffsetInCompostingLayer());
+ boxRect.move(contentOffsetInCompositingLayer());
FloatRoundedRect contentsClippingRect = renderer().style().getRoundedInnerBorderFor(boxRect).pixelSnappedRoundedRectForPainting(deviceScaleFactor());
if (clippingLayer()->setMasksToBoundsRect(contentsClippingRect)) {
clippingLayer()->setMaskLayer(nullptr);
@@ -2299,7 +2299,7 @@
m_graphicsLayer->setContentsRect(snapRectToDevicePixels(contentsBox(), deviceScaleFactor()));
LayoutRect boxRect(LayoutPoint(), imageRenderer.size());
- boxRect.move(contentOffsetInCompostingLayer());
+ boxRect.move(contentOffsetInCompositingLayer());
FloatRoundedRect contentsClippingRect = renderer().style().getRoundedInnerBorderFor(boxRect).pixelSnappedRoundedRectForPainting(deviceScaleFactor());
m_graphicsLayer->setContentsClippingRect(contentsClippingRect);
@@ -2327,7 +2327,7 @@
}
// Return the offset from the top-left of this compositing layer at which the renderer's contents are painted.
-LayoutSize RenderLayerBacking::contentOffsetInCompostingLayer() const
+LayoutSize RenderLayerBacking::contentOffsetInCompositingLayer() const
{
return LayoutSize(-m_compositedBounds.x() + m_compositedBoundsOffsetFromGraphicsLayer.width(), -m_compositedBounds.y() + m_compositedBoundsOffsetFromGraphicsLayer.height());
}
@@ -2350,7 +2350,7 @@
} else
contentsRect = renderBox.contentBoxRect();
- contentsRect.move(contentOffsetInCompostingLayer());
+ contentsRect.move(contentOffsetInCompositingLayer());
return contentsRect;
}
@@ -2377,7 +2377,7 @@
return FloatRect();
LayoutRect backgroundBox = backgroundRectForBox(downcast<RenderBox>(renderer()));
- backgroundBox.move(contentOffsetInCompostingLayer());
+ backgroundBox.move(contentOffsetInCompositingLayer());
return snapRectToDevicePixels(backgroundBox, deviceScaleFactor());
}
Modified: trunk/Source/WebCore/rendering/RenderLayerBacking.h (242699 => 242700)
--- trunk/Source/WebCore/rendering/RenderLayerBacking.h 2019-03-11 06:20:53 UTC (rev 242699)
+++ trunk/Source/WebCore/rendering/RenderLayerBacking.h 2019-03-11 12:58:57 UTC (rev 242700)
@@ -312,7 +312,7 @@
GraphicsLayerPaintingPhase paintingPhaseForPrimaryLayer() const;
- LayoutSize contentOffsetInCompostingLayer() const;
+ LayoutSize contentOffsetInCompositingLayer() const;
// Result is transform origin in device pixels.
FloatPoint3D computeTransformOriginForPainting(const LayoutRect& borderBox) const;
_______________________________________________
webkit-changes mailing list
[email protected]
https://lists.webkit.org/mailman/listinfo/webkit-changes