Title: [249290] trunk/Source/WebCore
Revision
249290
Author
[email protected]
Date
2019-08-29 13:48:02 -0700 (Thu, 29 Aug 2019)

Log Message

[LFC] Inline content logging should have some extra space for better readability
https://bugs.webkit.org/show_bug.cgi?id=201236
<rdar://problem/54807336>

Reviewed by Antti Koivisto.

* layout/layouttree/LayoutTreeBuilder.cpp:
(WebCore::Layout::outputInlineRuns):

Modified Paths

Diff

Modified: trunk/Source/WebCore/ChangeLog (249289 => 249290)


--- trunk/Source/WebCore/ChangeLog	2019-08-29 20:07:36 UTC (rev 249289)
+++ trunk/Source/WebCore/ChangeLog	2019-08-29 20:48:02 UTC (rev 249290)
@@ -1,5 +1,16 @@
 2019-08-29  Zalan Bujtas  <[email protected]>
 
+        [LFC] Inline content logging should have some extra space for better readability
+        https://bugs.webkit.org/show_bug.cgi?id=201236
+        <rdar://problem/54807336>
+
+        Reviewed by Antti Koivisto.
+
+        * layout/layouttree/LayoutTreeBuilder.cpp:
+        (WebCore::Layout::outputInlineRuns):
+
+2019-08-29  Zalan Bujtas  <[email protected]>
+
         [LFC][TFC] Use the "complicated-cases" category for computing the TFC root's height
         https://bugs.webkit.org/show_bug.cgi?id=201230
         <rdar://problem/54806131>

Modified: trunk/Source/WebCore/layout/layouttree/LayoutTreeBuilder.cpp (249289 => 249290)


--- trunk/Source/WebCore/layout/layouttree/LayoutTreeBuilder.cpp	2019-08-29 20:07:36 UTC (rev 249289)
+++ trunk/Source/WebCore/layout/layouttree/LayoutTreeBuilder.cpp	2019-08-29 20:48:02 UTC (rev 249290)
@@ -250,8 +250,9 @@
     auto& lineBoxes = inlineFormattingState.lineBoxes();
 
     unsigned printedCharacters = 0;
-    while (++printedCharacters <= depth * 3)
+    while (++printedCharacters <= depth * 2)
         stream << " ";
+    stream << "  ";
 
     stream << "lines are -> ";
     for (auto& lineBox : lineBoxes)
@@ -260,8 +261,9 @@
 
     for (auto& inlineRun : inlineRuns) {
         unsigned printedCharacters = 0;
-        while (++printedCharacters <= depth * 3)
+        while (++printedCharacters <= depth * 2)
             stream << " ";
+        stream << "  ";
         if (inlineRun->textContext())
             stream << "inline text box";
         else
_______________________________________________
webkit-changes mailing list
[email protected]
https://lists.webkit.org/mailman/listinfo/webkit-changes

Reply via email to