Title: [104522] trunk/Source/WebCore
Revision
104522
Author
[email protected]
Date
2012-01-09 17:21:14 -0800 (Mon, 09 Jan 2012)

Log Message

[chromium] Add documentation to updater classes
https://bugs.webkit.org/show_bug.cgi?id=75866

Reviewed by James Robinson.

* platform/graphics/chromium/BitmapCanvasLayerTextureUpdater.h:
* platform/graphics/chromium/BitmapSkPictureCanvasLayerTextureUpdater.h:
* platform/graphics/chromium/CanvasLayerTextureUpdater.h:
* platform/graphics/chromium/FrameBufferSkPictureCanvasLayerTextureUpdater.h:
* platform/graphics/chromium/SkPictureCanvasLayerTextureUpdater.h:

Modified Paths

Diff

Modified: trunk/Source/WebCore/ChangeLog (104521 => 104522)


--- trunk/Source/WebCore/ChangeLog	2012-01-10 01:14:16 UTC (rev 104521)
+++ trunk/Source/WebCore/ChangeLog	2012-01-10 01:21:14 UTC (rev 104522)
@@ -1,3 +1,16 @@
+2012-01-09  Nat Duca  <[email protected]>
+
+        [chromium] Add documentation to updater classes
+        https://bugs.webkit.org/show_bug.cgi?id=75866
+
+        Reviewed by James Robinson.
+
+        * platform/graphics/chromium/BitmapCanvasLayerTextureUpdater.h:
+        * platform/graphics/chromium/BitmapSkPictureCanvasLayerTextureUpdater.h:
+        * platform/graphics/chromium/CanvasLayerTextureUpdater.h:
+        * platform/graphics/chromium/FrameBufferSkPictureCanvasLayerTextureUpdater.h:
+        * platform/graphics/chromium/SkPictureCanvasLayerTextureUpdater.h:
+
 2012-01-09  Adam Barth  <[email protected]>
 
         Remove unused variable from CodeGeneratorV8

Modified: trunk/Source/WebCore/platform/graphics/chromium/BitmapCanvasLayerTextureUpdater.h (104521 => 104522)


--- trunk/Source/WebCore/platform/graphics/chromium/BitmapCanvasLayerTextureUpdater.h	2012-01-10 01:14:16 UTC (rev 104521)
+++ trunk/Source/WebCore/platform/graphics/chromium/BitmapCanvasLayerTextureUpdater.h	2012-01-10 01:21:14 UTC (rev 104522)
@@ -37,7 +37,9 @@
 
 class LayerPainterChromium;
 
-// A CanvasLayerTextureUpdater with an internal bitmap.
+// This class rasterizes the contentRect into a PlatformCanvas. It then updates
+// textures by copying from the canvas into the texture, using MapSubImage if
+// possible.
 class BitmapCanvasLayerTextureUpdater : public CanvasLayerTextureUpdater {
 public:
     class Texture : public LayerTextureUpdater::Texture {

Modified: trunk/Source/WebCore/platform/graphics/chromium/BitmapSkPictureCanvasLayerTextureUpdater.h (104521 => 104522)


--- trunk/Source/WebCore/platform/graphics/chromium/BitmapSkPictureCanvasLayerTextureUpdater.h	2012-01-10 01:14:16 UTC (rev 104521)
+++ trunk/Source/WebCore/platform/graphics/chromium/BitmapSkPictureCanvasLayerTextureUpdater.h	2012-01-10 01:21:14 UTC (rev 104522)
@@ -36,6 +36,8 @@
 
 namespace WebCore {
 
+// This class records the contentRect into an SkPicture, then software rasterizes
+// the SkPicture into bitmaps for each tile. This implements CCSettings::perTilePainting.
 class BitmapSkPictureCanvasLayerTextureUpdater : public SkPictureCanvasLayerTextureUpdater {
 public:
     class Texture : public CanvasLayerTextureUpdater::Texture {

Modified: trunk/Source/WebCore/platform/graphics/chromium/CanvasLayerTextureUpdater.h (104521 => 104522)


--- trunk/Source/WebCore/platform/graphics/chromium/CanvasLayerTextureUpdater.h	2012-01-10 01:14:16 UTC (rev 104521)
+++ trunk/Source/WebCore/platform/graphics/chromium/CanvasLayerTextureUpdater.h	2012-01-10 01:21:14 UTC (rev 104522)
@@ -36,7 +36,9 @@
 class GraphicsContext3D;
 class LayerPainterChromium;
 
-// A LayerTextureUpdater with an internal canvas.
+// Base class for BitmapCanvasLayerTextureUpdater and
+// SkPictureCanvasLayerTextureUpdater that reduces code duplication between
+// their respective paintContents implementations.
 class CanvasLayerTextureUpdater : public LayerTextureUpdater {
 public:
     virtual ~CanvasLayerTextureUpdater();

Modified: trunk/Source/WebCore/platform/graphics/chromium/FrameBufferSkPictureCanvasLayerTextureUpdater.h (104521 => 104522)


--- trunk/Source/WebCore/platform/graphics/chromium/FrameBufferSkPictureCanvasLayerTextureUpdater.h	2012-01-10 01:14:16 UTC (rev 104521)
+++ trunk/Source/WebCore/platform/graphics/chromium/FrameBufferSkPictureCanvasLayerTextureUpdater.h	2012-01-10 01:21:14 UTC (rev 104522)
@@ -34,6 +34,9 @@
 
 namespace WebCore {
 
+// This class records the contentRect into an SkPicture, then uses accelerated
+// drawing to update the texture. The accelerated drawing goes to an
+// intermediate framebuffer and then is copied to the destination texture once done.
 class FrameBufferSkPictureCanvasLayerTextureUpdater : public SkPictureCanvasLayerTextureUpdater {
 public:
     class Texture : public LayerTextureUpdater::Texture {

Modified: trunk/Source/WebCore/platform/graphics/chromium/SkPictureCanvasLayerTextureUpdater.h (104521 => 104522)


--- trunk/Source/WebCore/platform/graphics/chromium/SkPictureCanvasLayerTextureUpdater.h	2012-01-10 01:14:16 UTC (rev 104521)
+++ trunk/Source/WebCore/platform/graphics/chromium/SkPictureCanvasLayerTextureUpdater.h	2012-01-10 01:21:14 UTC (rev 104522)
@@ -39,6 +39,11 @@
 
 class LayerPainterChromium;
 
+// This class records the contentRect into an SkPicture. Subclasses, provide
+// different implementations of tile updating based on this recorded picture.
+// The BitmapSkPictureCanvasLayerTextureUpdater and
+// FrameBufferSkPictureCanvasLayerTextureUpdater are two examples of such
+// implementations.
 class SkPictureCanvasLayerTextureUpdater : public CanvasLayerTextureUpdater {
 public:
     virtual ~SkPictureCanvasLayerTextureUpdater();
_______________________________________________
webkit-changes mailing list
[email protected]
http://lists.webkit.org/mailman/listinfo.cgi/webkit-changes

Reply via email to