Title: [264514] trunk/Source
- Revision
- 264514
- Author
- [email protected]
- Date
- 2020-07-17 09:07:13 -0700 (Fri, 17 Jul 2020)
Log Message
Unreviewed, reverting r264482.
Part of an attempted fix for the build
Reverted changeset:
"Use AVRoutePickerView when available for choosing AirPlay
devices"
https://bugs.webkit.org/show_bug.cgi?id=213497
https://trac.webkit.org/changeset/264482
Modified Paths
Diff
Modified: trunk/Source/WTF/ChangeLog (264513 => 264514)
--- trunk/Source/WTF/ChangeLog 2020-07-17 16:05:52 UTC (rev 264513)
+++ trunk/Source/WTF/ChangeLog 2020-07-17 16:07:13 UTC (rev 264514)
@@ -1,3 +1,16 @@
+2020-07-17 Truitt Savell <[email protected]>
+
+ Unreviewed, reverting r264482.
+
+ Part of an attempted fix for the build
+
+ Reverted changeset:
+
+ "Use AVRoutePickerView when available for choosing AirPlay
+ devices"
+ https://bugs.webkit.org/show_bug.cgi?id=213497
+ https://trac.webkit.org/changeset/264482
+
2020-07-16 Xabier Rodriguez Calvar <[email protected]>
Rename createBoxPtr into adoptBoxPtr
Modified: trunk/Source/WTF/wtf/PlatformHave.h (264513 => 264514)
--- trunk/Source/WTF/wtf/PlatformHave.h 2020-07-17 16:05:52 UTC (rev 264513)
+++ trunk/Source/WTF/wtf/PlatformHave.h 2020-07-17 16:07:13 UTC (rev 264514)
@@ -695,7 +695,3 @@
|| (PLATFORM(APPLETV) && __TV_OS_VERSION_MIN_REQUIRED >= 140000)
#define HAVE_LSDATABASECONTEXT 1
#endif
-
-#if (PLATFORM(MAC) && __MAC_OS_X_VERSION_MIN_REQUIRED >= 101500)
-#define HAVE_AVROUTEPICKERVIEW 1
-#endif
Modified: trunk/Source/WebCore/ChangeLog (264513 => 264514)
--- trunk/Source/WebCore/ChangeLog 2020-07-17 16:05:52 UTC (rev 264513)
+++ trunk/Source/WebCore/ChangeLog 2020-07-17 16:07:13 UTC (rev 264514)
@@ -1,3 +1,16 @@
+2020-07-17 Truitt Savell <[email protected]>
+
+ Unreviewed, reverting r264482.
+
+ Part of an attempted fix for the build
+
+ Reverted changeset:
+
+ "Use AVRoutePickerView when available for choosing AirPlay
+ devices"
+ https://bugs.webkit.org/show_bug.cgi?id=213497
+ https://trac.webkit.org/changeset/264482
+
2020-07-17 Joonghun Park <[email protected]>
Unreviewed. Remove the build warning below since r264280.
Modified: trunk/Source/WebCore/platform/graphics/avfoundation/objc/AVRoutePickerViewTargetPicker.mm (264513 => 264514)
--- trunk/Source/WebCore/platform/graphics/avfoundation/objc/AVRoutePickerViewTargetPicker.mm 2020-07-17 16:05:52 UTC (rev 264513)
+++ trunk/Source/WebCore/platform/graphics/avfoundation/objc/AVRoutePickerViewTargetPicker.mm 2020-07-17 16:07:13 UTC (rev 264514)
@@ -26,7 +26,7 @@
#import "config.h"
#import "AVRoutePickerViewTargetPicker.h"
-#if ENABLE(WIRELESS_PLAYBACK_TARGET) && HAVE(AVROUTEPICKERVIEW)
+#if ENABLE(WIRELESS_PLAYBACK_TARGET) && !PLATFORM(IOS_FAMILY)
#import "Logging.h"
#import <AVFoundation/AVRouteDetector.h>
Modified: trunk/Source/WebCore/platform/graphics/avfoundation/objc/MediaPlaybackTargetPickerMac.mm (264513 => 264514)
--- trunk/Source/WebCore/platform/graphics/avfoundation/objc/MediaPlaybackTargetPickerMac.mm 2020-07-17 16:05:52 UTC (rev 264513)
+++ trunk/Source/WebCore/platform/graphics/avfoundation/objc/MediaPlaybackTargetPickerMac.mm 2020-07-17 16:07:13 UTC (rev 264514)
@@ -73,11 +73,9 @@
if (m_routePicker)
return *m_routePicker;
-#if HAVE(AVROUTEPICKERVIEW)
if (AVRoutePickerViewTargetPicker::isAvailable())
m_routePicker = makeUnique<AVRoutePickerViewTargetPicker>(*this);
else
-#endif
m_routePicker = makeUnique<AVOutputDeviceMenuControllerTargetPicker>(*this);
return *m_routePicker;
_______________________________________________
webkit-changes mailing list
[email protected]
https://lists.webkit.org/mailman/listinfo/webkit-changes