Title: [104748] trunk/Source/WebCore
- Revision
- 104748
- Author
- [email protected]
- Date
- 2012-01-11 14:44:32 -0800 (Wed, 11 Jan 2012)
Log Message
Switch web intents to use supplemental IDL for DOMWindow
https://bugs.webkit.org/show_bug.cgi?id=76092
Patch by Greg Billock <[email protected]> on 2012-01-11
Reviewed by Adam Barth.
* Modules/intents/DOMWindowIntents.idl: Added.
* WebCore.gypi:
* page/DOMWindow.idl:
Modified Paths
Added Paths
Diff
Modified: trunk/Source/WebCore/ChangeLog (104747 => 104748)
--- trunk/Source/WebCore/ChangeLog 2012-01-11 22:35:52 UTC (rev 104747)
+++ trunk/Source/WebCore/ChangeLog 2012-01-11 22:44:32 UTC (rev 104748)
@@ -1,3 +1,14 @@
+2012-01-11 Greg Billock <[email protected]>
+
+ Switch web intents to use supplemental IDL for DOMWindow
+ https://bugs.webkit.org/show_bug.cgi?id=76092
+
+ Reviewed by Adam Barth.
+
+ * Modules/intents/DOMWindowIntents.idl: Added.
+ * WebCore.gypi:
+ * page/DOMWindow.idl:
+
2012-01-11 Kent Tamura <[email protected]>
Rename HTMLInputElement::setDefaultName to setInitialName.
Added: trunk/Source/WebCore/Modules/intents/DOMWindowIntents.idl (0 => 104748)
--- trunk/Source/WebCore/Modules/intents/DOMWindowIntents.idl (rev 0)
+++ trunk/Source/WebCore/Modules/intents/DOMWindowIntents.idl 2012-01-11 22:44:32 UTC (rev 104748)
@@ -0,0 +1,29 @@
+/*
+ * Copyright (C) 2011 Google Inc. All rights reserved.
+ *
+ * This library is free software; you can redistribute it and/or
+ * modify it under the terms of the GNU Library General Public
+ * License as published by the Free Software Foundation; either
+ * version 2 of the License, or (at your option) any later version.
+ *
+ * This library is distributed in the hope that it will be useful,
+ * but WITHOUT ANY WARRANTY; without even the implied warranty of
+ * MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+ * Library General Public License for more details.
+ *
+ * You should have received a copy of the GNU Library General Public License
+ * along with this library; see the file COPYING.LIB. If not, write to
+ * the Free Software Foundation, Inc., 51 Franklin Street, Fifth Floor,
+ * Boston, MA 02110-1301, USA.
+ */
+
+module window {
+
+ interface [
+ Conditional=WEB_INTENTS,
+ Supplemental=DOMWindow
+ ] DOMWindowIntents {
+ attribute IntentConstructor Intent;
+ };
+
+}
Modified: trunk/Source/WebCore/WebCore.gypi (104747 => 104748)
--- trunk/Source/WebCore/WebCore.gypi 2012-01-11 22:35:52 UTC (rev 104747)
+++ trunk/Source/WebCore/WebCore.gypi 2012-01-11 22:44:32 UTC (rev 104748)
@@ -1149,6 +1149,7 @@
'Modules/gamepad/Gamepad.idl',
'Modules/gamepad/GamepadList.idl',
'Modules/gamepad/NavigatorGamepad.idl',
+ 'Modules/intents/DOMWindowIntents.idl',
'Modules/intents/Intent.idl',
'Modules/intents/IntentResultCallback.idl',
'Modules/intents/NavigatorIntents.idl',
Modified: trunk/Source/WebCore/page/DOMWindow.idl (104747 => 104748)
--- trunk/Source/WebCore/page/DOMWindow.idl 2012-01-11 22:35:52 UTC (rev 104747)
+++ trunk/Source/WebCore/page/DOMWindow.idl 2012-01-11 22:44:32 UTC (rev 104748)
@@ -603,8 +603,6 @@
attribute [EnabledAtRuntime=webkitVideoTrack] TrackEventConstructor TrackEvent;
#endif
- attribute [Conditional=WEB_INTENTS] IntentConstructor Intent; // Usable with the new operator
-
attribute DOMPluginConstructor Plugin;
attribute DOMPluginArrayConstructor PluginArray;
_______________________________________________
webkit-changes mailing list
[email protected]
http://lists.webkit.org/mailman/listinfo.cgi/webkit-changes