Title: [282431] trunk/Tools
Revision
282431
Author
[email protected]
Date
2021-09-14 20:39:52 -0700 (Tue, 14 Sep 2021)

Log Message

Rename RESOURCE_LOAD_STATISTICS to INTELLIGENT_TRACKING_PREVENTION
https://bugs.webkit.org/show_bug.cgi?id=230279
<rdar://problem/83118683>

Reviewed by John Wilander.

Followup renaming the variables in FeatureList.pm.

* Scripts/webkitperl/FeatureList.pm:

Modified Paths

Diff

Modified: trunk/Tools/ChangeLog (282430 => 282431)


--- trunk/Tools/ChangeLog	2021-09-15 02:28:47 UTC (rev 282430)
+++ trunk/Tools/ChangeLog	2021-09-15 03:39:52 UTC (rev 282431)
@@ -1,3 +1,15 @@
+2021-09-14  Don Olmstead  <[email protected]>
+
+        Rename RESOURCE_LOAD_STATISTICS to INTELLIGENT_TRACKING_PREVENTION
+        https://bugs.webkit.org/show_bug.cgi?id=230279
+        <rdar://problem/83118683>
+
+        Reviewed by John Wilander.
+
+        Followup renaming the variables in FeatureList.pm.
+
+        * Scripts/webkitperl/FeatureList.pm:
+
 2021-09-14  John Wilander  <[email protected]>
 
         Rename RESOURCE_LOAD_STATISTICS to INTELLIGENT_TRACKING_PREVENTION

Modified: trunk/Tools/Scripts/webkitperl/FeatureList.pm (282430 => 282431)


--- trunk/Tools/Scripts/webkitperl/FeatureList.pm	2021-09-15 02:28:47 UTC (rev 282430)
+++ trunk/Tools/Scripts/webkitperl/FeatureList.pm	2021-09-15 03:39:52 UTC (rev 282431)
@@ -103,6 +103,7 @@
     $inputTypeWeekSupport,
     $inspectorAlternateDispatchersSupport,
     $inspectorTelemetrySupport,
+    $intelligentTrackingPrevention,
     $intersectionObserverSupport,
     $iosGestureEventsSupport,
     $iosTouchEventsSupport,
@@ -142,7 +143,6 @@
     $remoteInspectorSupport,
     $resizeObserverSupport,
     $resolutionMediaQuerySupport,
-    $resourceLoadStatisticsSupport,
     $resourceUsageSupport,
     $rubberBandingSupport,
     $samplingProfilerSupport,
@@ -347,6 +347,9 @@
     { option => "inspector-telemetry", desc => "Toggle inspector telemetry support",
       define => "ENABLE_INSPECTOR_TELEMETRY", value => \$inspectorTelemetrySupport },
 
+    { option => "intelligent-tracking-prevention", desc => "Toggle intelligent tracking prevention support",
+      define => "ENABLE_INTELLIGENT_TRACKING_PREVENTION", value => \$intelligentTrackingPrevention },
+
     { option => "intersection-observer", desc => "Enable Intersection Observer support",
       define => "ENABLE_INTERSECTION_OBSERVER", value => \$intersectionObserverSupport },
 
@@ -458,9 +461,6 @@
     { option => "resolution-media-query", desc => "Toggle resolution media query support",
       define => "ENABLE_RESOLUTION_MEDIA_QUERY", value => \$resolutionMediaQuerySupport },
 
-    { option => "resource-load-statistics", desc => "Toggle resource load statistics support",
-      define => "ENABLE_RESOURCE_LOAD_STATISTICS", value => \$resourceLoadStatisticsSupport },
-
     { option => "resource-usage", desc => "Toggle resource usage support",
       define => "ENABLE_RESOURCE_USAGE", value => \$resourceUsageSupport },
 
_______________________________________________
webkit-changes mailing list
[email protected]
https://lists.webkit.org/mailman/listinfo/webkit-changes

Reply via email to