Title: [107137] trunk/Source/WebCore
- Revision
- 107137
- Author
- [email protected]
- Date
- 2012-02-08 15:14:46 -0800 (Wed, 08 Feb 2012)
Log Message
Remove [CustomHeader] from CanvasPixelArray and rename [CustomHeader] to [JSCustomHeader]
https://bugs.webkit.org/show_bug.cgi?id=78089
Reviewed by Adam Barth.
This patch removes [CustomHeader] from CanvasPixelArray.idl, since CanvasPixelArrayCustom.h
does not exist. (The reason why missing CanvasPixelArrayCustom.h has not caused build failure
is that [CustomHeader] has been JSC-specific and JSC has not enabled CanvasPixelArray.)
Also, this patch renames [CustomHeader] to [JSCustomHeader], since whether a given class
should have custom header or not will depend on _javascript_ bindings.
No tests. No change in behavior.
* bindings/scripts/CodeGeneratorJS.pm:
(GenerateHeader):
* dom/Node.idl:
* html/canvas/CanvasPixelArray.idl:
Modified Paths
Diff
Modified: trunk/Source/WebCore/ChangeLog (107136 => 107137)
--- trunk/Source/WebCore/ChangeLog 2012-02-08 23:08:24 UTC (rev 107136)
+++ trunk/Source/WebCore/ChangeLog 2012-02-08 23:14:46 UTC (rev 107137)
@@ -1,3 +1,23 @@
+2012-02-08 Kentaro Hara <[email protected]>
+
+ Remove [CustomHeader] from CanvasPixelArray and rename [CustomHeader] to [JSCustomHeader]
+ https://bugs.webkit.org/show_bug.cgi?id=78089
+
+ Reviewed by Adam Barth.
+
+ This patch removes [CustomHeader] from CanvasPixelArray.idl, since CanvasPixelArrayCustom.h
+ does not exist. (The reason why missing CanvasPixelArrayCustom.h has not caused build failure
+ is that [CustomHeader] has been JSC-specific and JSC has not enabled CanvasPixelArray.)
+ Also, this patch renames [CustomHeader] to [JSCustomHeader], since whether a given class
+ should have custom header or not will depend on _javascript_ bindings.
+
+ No tests. No change in behavior.
+
+ * bindings/scripts/CodeGeneratorJS.pm:
+ (GenerateHeader):
+ * dom/Node.idl:
+ * html/canvas/CanvasPixelArray.idl:
+
2012-02-08 Zalan Bujtas <[email protected]>
Dispatch updateViewportArguments(), when Document is finished
Modified: trunk/Source/WebCore/bindings/scripts/CodeGeneratorJS.pm (107136 => 107137)
--- trunk/Source/WebCore/bindings/scripts/CodeGeneratorJS.pm 2012-02-08 23:08:24 UTC (rev 107136)
+++ trunk/Source/WebCore/bindings/scripts/CodeGeneratorJS.pm 2012-02-08 23:14:46 UTC (rev 107137)
@@ -749,9 +749,9 @@
# Prototype
push(@headerContent, " static JSC::JSObject* createPrototype(JSC::ExecState*, JSC::JSGlobalObject*);\n") unless ($dataNode->extendedAttributes->{"ExtendsDOMGlobalObject"});
- $headerTrailingIncludes{"${className}Custom.h"} = 1 if $dataNode->extendedAttributes->{"CustomHeader"};
+ $headerTrailingIncludes{"${className}Custom.h"} = 1 if $dataNode->extendedAttributes->{"JSCustomHeader"};
- $implIncludes{"${className}Custom.h"} = 1 if !$dataNode->extendedAttributes->{"CustomHeader"} && ($dataNode->extendedAttributes->{"CustomPutFunction"} || $dataNode->extendedAttributes->{"CustomNamedSetter"});
+ $implIncludes{"${className}Custom.h"} = 1 if !$dataNode->extendedAttributes->{"JSCustomHeader"} && ($dataNode->extendedAttributes->{"CustomPutFunction"} || $dataNode->extendedAttributes->{"CustomNamedSetter"});
my $hasGetter = $numAttributes > 0
|| !$dataNode->extendedAttributes->{"OmitConstructor"}
Modified: trunk/Source/WebCore/dom/Node.idl (107136 => 107137)
--- trunk/Source/WebCore/dom/Node.idl 2012-02-08 23:08:24 UTC (rev 107136)
+++ trunk/Source/WebCore/dom/Node.idl 2012-02-08 23:14:46 UTC (rev 107137)
@@ -21,7 +21,7 @@
module core {
interface [
- CustomHeader,
+ JSCustomHeader,
JSCustomMarkFunction,
JSCustomPushEventHandlerScope,
JSCustomIsReachable,
Modified: trunk/Source/WebCore/html/canvas/CanvasPixelArray.idl (107136 => 107137)
--- trunk/Source/WebCore/html/canvas/CanvasPixelArray.idl 2012-02-08 23:08:24 UTC (rev 107136)
+++ trunk/Source/WebCore/html/canvas/CanvasPixelArray.idl 2012-02-08 23:14:46 UTC (rev 107137)
@@ -30,7 +30,6 @@
#if !defined(LANGUAGE_JAVASCRIPT) || !LANGUAGE_JAVASCRIPT || defined(V8_BINDING) && V8_BINDING
interface [
OmitConstructor,
- CustomHeader,
HasNumericIndexGetter,
CustomIndexedSetter
] CanvasPixelArray {
_______________________________________________
webkit-changes mailing list
[email protected]
http://lists.webkit.org/mailman/listinfo.cgi/webkit-changes