Branch: refs/heads/main
  Home:   https://github.com/WebKit/WebKit
  Commit: 2c2726ff90d9d3ec95f1516b0c42c2de33668e6e
      
https://github.com/WebKit/WebKit/commit/2c2726ff90d9d3ec95f1516b0c42c2de33668e6e
  Author: Tim Nguyen <[email protected]>
  Date:   2023-03-14 (Tue, 14 Mar 2023)

  Changed paths:
    M Source/WebCore/css/ComputedStyleExtractor.cpp
    M Source/WebCore/rendering/RenderListMarker.cpp
    M Source/WebCore/rendering/style/ListStyleType.cpp
    M Source/WebCore/rendering/style/ListStyleType.h
    M Source/WebCore/style/StyleBuilderConverter.h

  Log Message:
  -----------
  Rename ListStyleType::Type::CustomCounterStyle to CounterStyle
https://bugs.webkit.org/show_bug.cgi?id=253932
rdar://106736501

Reviewed by Antti Koivisto.

UA styles will also be handled through this `CustomCounterStyle` type, so the 
`Custom` part isn't relevant.

* Source/WebCore/css/ComputedStyleExtractor.cpp:
(WebCore::ComputedStyleExtractor::valueForPropertyInStyle):
* Source/WebCore/rendering/RenderListMarker.cpp:
(WebCore::effectiveListMarkerType):
(WebCore::listMarkerSuffix):
(WebCore::listMarkerText):
(WebCore::RenderListMarker::updateContent):
* Source/WebCore/rendering/style/ListStyleType.cpp:
(WebCore::operator<<):
* Source/WebCore/rendering/style/ListStyleType.h:
* Source/WebCore/style/StyleBuilderConverter.h:
(WebCore::Style::BuilderConverter::convertListStyleType):

Canonical link: https://commits.webkit.org/261676@main


_______________________________________________
webkit-changes mailing list
[email protected]
https://lists.webkit.org/mailman/listinfo/webkit-changes

Reply via email to