Branch: refs/heads/webkitglib/2.52
Home: https://github.com/WebKit/WebKit
Commit: 9309302557c960412c65a6da7aa576268548d983
https://github.com/WebKit/WebKit/commit/9309302557c960412c65a6da7aa576268548d983
Author: Lauro Moura <[email protected]>
Date: 2026-06-25 (Thu, 25 Jun 2026)
Changed paths:
M Tools/Scripts/webkitpy/port/gtk.py
M Tools/Scripts/webkitpy/port/gtk_unittest.py
M Tools/Scripts/webkitpy/port/wpe.py
M Tools/Scripts/webkitpy/port/wpe_unittest.py
Log Message:
-----------
Cherry-pick 306101@main (6a1eadfc3e3e).
https://bugs.webkit.org/show_bug.cgi?id=214511
[GTK][resultsdb] Remove version_name from the uploaded results
https://bugs.webkit.org/show_bug.cgi?id=214511
Reviewed by Carlos Alberto Lopez Perez.
305707@main changed WPE and GTK to use the project version as the result
upload version instead of the kernel version, resulting in more stable
versioning.
Meanwhile, GTK still uses the display server name as the version_name.
This causes the frontend code to group different configurations with
different versions together in a single timeline, also dropping the
platform name and version, as it's implied from the version_name. Thus
for GTK we had rows with the cryptic title `Xvfb wk2 Debug...`.
On top of that, we have bugs like bug306091, where markers are not
rendered when configurations are grouped out of order. As the default
GTK timelines were grouped by version_name, it was more prone to be
affected by this problem than WPE.
This commit ensures we send an empty version_name field for both WPE and
GTK, aligning their behavior.
In fact, if we need the display server name in the future, we can add it
back as a different flavor.
Note that with the current resultsdbpy frontend code, this will create a
new result series for GTK on front page (i.e. decoupled from the
'Xvfb' group). But over time, the old configurations will be archived
out of the front page. And for long term history of GTK/WPE, we can use
tools like webkit-testhunter.
* Tools/Scripts/webkitpy/port/gtk.py:
(GtkPort.configuration_for_upload):
* Tools/Scripts/webkitpy/port/gtk_unittest.py:
(GtkPortTest.test_default_upload_configuration):
* Tools/Scripts/webkitpy/port/wpe.py:
(WPEPort.configuration_for_upload):
* Tools/Scripts/webkitpy/port/wpe_unittest.py:
(WPEPortTest.test_default_upload_configuration):
Canonical link: https://commits.webkit.org/306101@main
Canonical link: https://commits.webkit.org/305877.793@webkitglib/2.52
Commit: 266f66a82469266b6a2484006acd39c4449e7875
https://github.com/WebKit/WebKit/commit/266f66a82469266b6a2484006acd39c4449e7875
Author: Lauro Moura <[email protected]>
Date: 2026-06-25 (Thu, 25 Jun 2026)
Changed paths:
M Tools/Scripts/webkitpy/port/glib.py
M Tools/Scripts/webkitpy/port/gtk.py
M Tools/Scripts/webkitpy/port/gtk_unittest.py
M Tools/Scripts/webkitpy/port/wpe.py
M Tools/Scripts/webkitpy/port/wpe_unittest.py
Log Message:
-----------
Cherry-pick 308721@main (1927f6c9ffc4).
https://bugs.webkit.org/show_bug.cgi?id=309249
[webkitpy][GLIB] Fix architecture field value for glib Port classes
https://bugs.webkit.org/show_bug.cgi?id=309249
Reviewed by Carlos Alberto Lopez Perez.
Replace the currently hardcoded x86 architecture with runtime detection.
This fixes the results uploaded by the new ARM64 testers (307868@main).
Currently, they have the same x86 architecture as the x86_64, making it
hard to follow the history, especially when the outcome differ. For
example, while the x86_64 bot is in a good shape, queries to the
results database showed alternating green and red runs.
This commit also expands the list of test configurations for the glib
ports, covering both the default x86_64 and arm64 architectures, and
enabling architecture-specific expectations within the same expectation
file, for example:
[ arm64 ] some/test.html [ Crash ]
* Tools/Scripts/webkitpy/port/glib.py:
(GLibPort):
(GLibPort.architecture):
(GLibPort._generate_all_test_configurations):
* Tools/Scripts/webkitpy/port/gtk.py:
(GtkPort.setup_environ_for_server):
(GtkPort._generate_all_test_configurations): Deleted.
* Tools/Scripts/webkitpy/port/gtk_unittest.py:
(GtkPortTest.test_architecture_default):
(GtkPortTest):
(GtkPortTest.test_architecture_cli_override):
(GtkPortTest.test_architecture_aarch64_normalization):
(GtkPortTest.test_architecture_cli_override_aarch64):
(GtkPortTest.test_all_test_configurations_architectures):
* Tools/Scripts/webkitpy/port/wpe.py:
(WPEPort.check_sys_deps):
(WPEPort._generate_all_test_configurations): Deleted.
* Tools/Scripts/webkitpy/port/wpe_unittest.py:
(WPEPortTest.test_architecture_default):
(WPEPortTest):
(WPEPortTest.test_architecture_cli_override):
(WPEPortTest.test_architecture_aarch64_normalization):
(WPEPortTest.test_architecture_cli_override_aarch64):
(WPEPortTest.test_all_test_configurations_architectures):
Canonical link: https://commits.webkit.org/308721@main
Canonical link: https://commits.webkit.org/305877.794@webkitglib/2.52
Commit: a8c7fc7d1b730104351bf740199ec5ab3839b1b2
https://github.com/WebKit/WebKit/commit/a8c7fc7d1b730104351bf740199ec5ab3839b1b2
Author: Lauro Moura <[email protected]>
Date: 2026-06-25 (Thu, 25 Jun 2026)
Changed paths:
M Tools/Scripts/webkitpy/common/test_expectations.py
M Tools/Scripts/webkitpy/common/test_expectations_unittest.py
M Tools/Scripts/webkitpy/webdriver_tests/webdriver_test_runner.py
M Tools/glib/api_test_runner.py
Log Message:
-----------
Cherry-pick 309066@main (3beb04a4553f).
https://bugs.webkit.org/show_bug.cgi?id=309580
[webkitpy][GLIB] Add support to architecture markers in
TestExpectations.json
https://bugs.webkit.org/show_bug.cgi?id=309580
Reviewed by Carlos Alberto Lopez Perez.
Follow-up of 308721@main, which replaced the hardcoded x86 architecture
for glib ports with runtime detection.
TestExpectations.json uses a string as the key selector to decide
whether to apply or not a given expectation. This is typically one of
'all', 'gtk', and 'wpe', followed by an optional '@BuildType' suffix.
This commit extends the expectation syntax in TestExpectations.json,
adding a marker for the architecture, after the ':' wildcard, to
contrast with the '@' used for the build type. So, an expectation that
targets WPE Debug ARM64 would be written as 'wpe@Debug:arm64'.
With the addition of this new parameter, to account for the various
possible configurations, we also changed the precedence check to roughly
match the LayoutTests scheme, where the most specific expectation wins.
Previously, 'gtk' would be selected over 'gtk@Release', for example.
Note that 'all' is a fallback port name, so 'all@Debug:x86_64' would
still lose over a proper port name like 'gtk' or 'wpe'.
As these extended configurations were rarely used (~9 commits in 8
years) and the new precedence did not break the existing tests, this
should not be a problem. The new checks are also covered by new tests.
* Tools/Scripts/webkitpy/common/test_expectations.py:
(TestExpectations.__init__):
(TestExpectations._port_name_for_expected):
* Tools/Scripts/webkitpy/common/test_expectations_unittest.py:
(MockTestExpectations.__init__):
(test_architecture):
(test_specificity):
(test_architecture_slow):
(test_architecture_skip):
* Tools/Scripts/webkitpy/webdriver_tests/webdriver_test_runner.py:
(WebDriverTestRunner.__init__):
* Tools/glib/api_test_runner.py:
(TestRunner.__init__):
Canonical link: https://commits.webkit.org/309066@main
Canonical link: https://commits.webkit.org/305877.795@webkitglib/2.52
Compare: https://github.com/WebKit/WebKit/compare/b30184be318d...a8c7fc7d1b73
To unsubscribe from these emails, change your notification settings at
https://github.com/WebKit/WebKit/settings/notifications