Branch: refs/heads/main
Home: https://github.com/WebKit/WebKit
Commit: 92f6bcd1fd07c46ffc7bdfef2342768926615145
https://github.com/WebKit/WebKit/commit/92f6bcd1fd07c46ffc7bdfef2342768926615145
Author: lilly <[email protected]>
Date: 2026-07-15 (Wed, 15 Jul 2026)
Changed paths:
M Source/WebCore/platform/graphics/CornerShapeUtilities.cpp
Log Message:
-----------
corner-shape: Clean up buildBevelCorners to match spec terminology
https://bugs.webkit.org/show_bug.cgi?id=319419
rdar://182243334
Reviewed by Simon Fraser.
buildBevelCorners() uses local names that don't line up with the CSS Borders
and Box Decorations Level 4 "border-aligned corner clip-out path" algorithm,
making it hard to check the code against the spec. Also considering some
variables
represent the same thing in adjustCornerforInset so this change syncs them
Rename and restructure for clarity, with no behavior change:
- inwardNormal -> strokeDirection
- innerStart / innerEnd -> adjustedCornerStart / adjustedCornerEnd
- Compute the intersection lines through an explicit midpoint controlPoint
(midPoint(adjustedCornerStart, adjustedCornerEnd)) rather than the raw
start/end pair. The midpoint lies on the start->end line, so the intersection
is identical; this just names the construct the way the spec does.
No functional change; this is a readability / spec-alignment cleanup. New tests
are not necessary here
* Source/WebCore/platform/graphics/CornerShapeUtilities.cpp:
Canonical link: https://commits.webkit.org/317243@main
To unsubscribe from these emails, change your notification settings at
https://github.com/WebKit/WebKit/settings/notifications