Branch: refs/heads/main
  Home:   https://github.com/WebKit/WebKit
  Commit: 8d081b822aea5a7f9c903b4a39d8056ee861ac75
      
https://github.com/WebKit/WebKit/commit/8d081b822aea5a7f9c903b4a39d8056ee861ac75
  Author: Alan Baradlay <[email protected]>
  Date:   2026-07-17 (Fri, 17 Jul 2026)

  Changed paths:
    M Source/WebCore/rendering/RenderFlexLayout.cpp
    M Source/WebCore/rendering/RenderFlexLayout.h

  Log Message:
  -----------
  [cleanup] Rename FlexLayout's positionList to flexItemsPositionList
https://bugs.webkit.org/show_bug.cgi?id=318644

Reviewed by Antti Koivisto.

positionList held each flex item's position, but the name did not say whose. 
Rename it to
flexItemsPositionList, matching the per-item flexItems...List naming the rest 
of the pipeline already
uses (flexItemsMainSizeList, flexItemsCrossSizeList, flexItemsCrossOffsetList) 
and mirroring
flexLinesCrossPositionList for lines. The placeFlexItems / layoutColumnReverse 
span parameter stays
named positions, since it is a per-line subspan rather than the whole list.

No change in behavior.

* Source/WebCore/rendering/RenderFlexLayout.cpp:
* Source/WebCore/rendering/RenderFlexLayout.h:

Canonical link: https://commits.webkit.org/317436@main



To unsubscribe from these emails, change your notification settings at 
https://github.com/WebKit/WebKit/settings/notifications

Reply via email to