Branch: refs/heads/main
  Home:   https://github.com/WebKit/WebKit
  Commit: 8320da5a64dc8edaec8630a36f84d8803572b9e7
      
https://github.com/WebKit/WebKit/commit/8320da5a64dc8edaec8630a36f84d8803572b9e7
  Author: Ahmad Saleem <[email protected]>
  Date:   2026-07-18 (Sat, 18 Jul 2026)

  Changed paths:
    M Source/WebCore/inspector/agents/InspectorNetworkAgent.cpp

  Log Message:
  -----------
  Web Inspector: buildWebSocketMessage() uses magic number 1 instead of 
WebSocketFrame::OpCodeText
https://bugs.webkit.org/show_bug.cgi?id=319755
rdar://182605625

Reviewed by Devin Rousso.

* Source/WebCore/inspector/agents/InspectorNetworkAgent.cpp:
(buildWebSocketMessage): Use the named WebSocketFrame::OpCodeText enumerator
instead of the bare literal 1 when deciding whether to report the payload
as UTF-8 text or base64.

Canonical link: https://commits.webkit.org/317484@main



To unsubscribe from these emails, change your notification settings at 
https://github.com/WebKit/WebKit/settings/notifications

Reply via email to