Branch: refs/heads/main
  Home:   https://github.com/WebKit/WebKit
  Commit: ae6f786db13d0bc15dfe1726dd5c0ada20843e5c
      
https://github.com/WebKit/WebKit/commit/ae6f786db13d0bc15dfe1726dd5c0ada20843e5c
  Author: Sam Weinig <[email protected]>
  Date:   2026-08-26 (Wed, 26 Aug 2026)

  Changed paths:
    M Source/WebCore/style/values/primitives/StyleLengthResolution.cpp

  Log Message:
  -----------
  [Cleanup] Streamline the viewport-percentage unit resolution functions
https://bugs.webkit.org/show_bug.cgi?id=322518

Reviewed by Darin Adler.

Simplify the logic for viewport-percentage unit resolution, removing a
bit of duplicate logic.

* Source/WebCore/style/values/primitives/StyleLengthResolution.cpp:
(WebCore::Style::resolveViewportLogicalAxis):
(WebCore::Style::resolveViewportAxis):
(WebCore::Style::resolveViewportType):
(WebCore::Style::resolveViewportUnit):
(WebCore::Style::resolveLengthImpl):
(WebCore::Style::resolveViewportPercentagePhysicalAxis): Deleted.
(WebCore::Style::resolveViewportPercentageLogicalAxis): Deleted.
(WebCore::Style::resolveViewportPercentageUnit): Deleted.

Canonical link: https://commits.webkit.org/319862@main



To unsubscribe from these emails, change your notification settings at 
https://github.com/WebKit/WebKit/settings/notifications

Reply via email to