Branch: refs/heads/webkitglib/2.54
  Home:   https://github.com/WebKit/WebKit
  Commit: bb2055dc07b877fa4df68afbb06bc591536b009b
      
https://github.com/WebKit/WebKit/commit/bb2055dc07b877fa4df68afbb06bc591536b009b
  Author: Adrian Perez de Castro <[email protected]>
  Date:   2026-09-15 (Tue, 15 Sep 2026)

  Changed paths:
    M Source/WebKit/WPEPlatform/docs/migrating-from-libwpe.md
    M Source/WebKit/WPEPlatform/docs/migration-mapping.md
    M Source/WebKit/WPEPlatform/docs/tutorial-browser.md
    M Source/WebKit/WPEPlatform/docs/tutorial-platform.md
    M Source/WebKit/WPEPlatform/wpe/WPEDisplay.cpp
    M Source/WebKit/WPEPlatform/wpe/drm/WPEDisplayDRM.cpp
    M Source/WebKit/WPEPlatform/wpe/headless/WPEDisplayHeadless.cpp
    M Source/WebKit/WPEPlatform/wpe/wayland/WPEDisplayWayland.cpp
    M Tools/Scripts/webkitpy/port/headlessdriver.py
    M Tools/Scripts/webkitpy/port/headlessdriver_unittest.py
    M Tools/Scripts/webkitpy/port/waylanddriver.py
    M Tools/Scripts/webkitpy/port/waylanddriver_unittest.py
    M Tools/Scripts/webkitpy/port/westondriver.py
    M Tools/Scripts/webkitpy/port/westondriver_unittest.py
    M Tools/Scripts/webkitpy/port/wpe_unittest.py
    M Tools/TestWebKitAPI/glib/WPEPlatform/mock/WPEDisplayMock.cpp
    M Tools/glib/api_test_runner.py

  Log Message:
  -----------
  Cherry-pick 321163@main (8b159f8ff07f). 
https://bugs.webkit.org/show_bug.cgi?id=324185

    [WPEPlatform] Remove "wpe-display-" prefix from built-in platform names
    https://bugs.webkit.org/show_bug.cgi?id=324185

    Reviewed by Carlos Garcia Campos and Patrick Griffis.

    Remove the common platform implementation name prefixes, which are not
    needed because names are scoped to each GIO extension point. That is: an
    implementation named "wanda" is intrinsically different than another
    with the same name for a different extension point and will not cause
    conflicts with each other. For the sake of naming consistency, use
    WPE_PLATFORM as the environment variable to read the platform
    implementation name from.

    On top of renaming the extension point implementation and environment
    variable names, the documentation and test infrastructure is modified
    accordingly.

    * Source/WebKit/WPEPlatform/docs/tutorial-browser.md:
    * Source/WebKit/WPEPlatform/wpe/drm/WPEDisplayDRM.cpp:
    * Source/WebKit/WPEPlatform/wpe/headless/WPEDisplayHeadless.cpp:
    * Source/WebKit/WPEPlatform/wpe/wayland/WPEDisplayWayland.cpp:
    * Source/WebKit/WPEPlatform/docs/tutorial-platform.md:
    * Tools/Scripts/webkitpy/port/headlessdriver.py:
    (HeadlessDriver._setup_environ_for_test):
    * Tools/Scripts/webkitpy/port/headlessdriver_unittest.py:
    (HeadlessDriverTest.make_environment):
    (HeadlessDriverTest.test_environment_needed_variables):
    * Tools/Scripts/webkitpy/port/waylanddriver.py:
    (WaylandDriver._setup_environ_for_test):
    * Tools/Scripts/webkitpy/port/waylanddriver_unittest.py:
    (WaylandDriverTest.make_environment):
    (WaylandDriverTest.test_environment_needed_variables):
    * Tools/Scripts/webkitpy/port/westondriver.py:
    (WestonDriver._setup_environ_for_test):
    * Tools/Scripts/webkitpy/port/westondriver_unittest.py:
    (WestonDriverTest.test_environment_needed_variables):
    * Tools/Scripts/webkitpy/port/wpe_unittest.py:
    (WPEPortTest.test_setup_environ_for_test_wpe_prefix):
    * Tools/TestWebKitAPI/glib/WPEPlatform/mock/WPEDisplayMock.cpp:
    (wpeDisplayMockRegister):
    * Source/WebKit/WPEPlatform/wpe/WPEDisplay.cpp:
    (wpe_display_get_default):
    * Source/WebKit/WPEPlatform/docs/migrating-from-libwpe.md:
    * Source/WebKit/WPEPlatform/docs/migration-mapping.md:
    * Tools/glib/api_test_runner.py:
    (TestRunner._setup_testing_environment_for_driver):

    Canonical link: https://commits.webkit.org/321163@main

Canonical link: https://commits.webkit.org/317695.317@webkitglib/2.54



To unsubscribe from these emails, change your notification settings at 
https://github.com/WebKit/WebKit/settings/notifications

Reply via email to