Branch: refs/heads/main
  Home:   https://github.com/WebKit/WebKit
  Commit: 915b253e25b25b893411878888226aaa4b69d8f9
      
https://github.com/WebKit/WebKit/commit/915b253e25b25b893411878888226aaa4b69d8f9
  Author: Kimmo Kinnunen <[email protected]>
  Date:   2026-09-23 (Wed, 23 Sep 2026)

  Changed paths:
    M Source/WebCore/Modules/WebGPU/Implementation/WebGPUBufferImpl.cpp
    M Source/WebGPU/WebGPU/Buffer.h
    M Source/WebGPU/WebGPU/Buffer.mm
    M Source/WebGPU/WebGPU/WebGPU.h
    M Source/WebGPU/WebGPU/WebGPUInternal.h

  Log Message:
  -----------
  WebGPU: Rename WGPUBufferMapAsyncStatus to WGPUMapAsyncStatus
https://bugs.webkit.org/show_bug.cgi?id=324803
rdar://188063565

Reviewed by Mike Wyrzykowski.

Rename WGPUBufferMapAsyncStatus to WGPUMapAsyncStatus. This makes it
match the standard webgpu.h. Since WebGPU.h arbitrarily mimics webgpu.h,
there is no benefit in deviating.

This is work towards being able to use WebGPU.h in ANGLE/WebGPU that
uses the standard webgpu.h interface.

* Source/WebCore/Modules/WebGPU/Implementation/WebGPUBufferImpl.cpp:
(WebCore::WebGPU::mapAsyncCallback):
(WebCore::WebGPU::BufferImpl::mapAsync):
* Source/WebGPU/WebGPU/Buffer.h:
* Source/WebGPU/WebGPU/Buffer.mm:
(WebGPU::Buffer::mapAsync):
(wgpuBufferMapAsync):
(wgpuBufferMapAsyncWithBlock):
* Source/WebGPU/WebGPU/WebGPU.h:
* Source/WebGPU/WebGPU/WebGPUInternal.h:

Canonical link: https://commits.webkit.org/321678@main



To unsubscribe from these emails, change your notification settings at 
https://github.com/WebKit/WebKit/settings/notifications

Reply via email to