Branch: refs/heads/main
  Home:   https://github.com/WebKit/WebKit
  Commit: f4582844db1a3a155d2b8cd20b14ce2af96ddbfd
      
https://github.com/WebKit/WebKit/commit/f4582844db1a3a155d2b8cd20b14ce2af96ddbfd
  Author: Kimmo Kinnunen <[email protected]>
  Date:   2026-09-22 (Tue, 22 Sep 2026)

  Changed paths:
    M Source/WebCore/Modules/WebGPU/Implementation/WebGPUDeviceImpl.cpp
    M Source/WebGPU/WebGPU/WebGPU.h

  Log Message:
  -----------
  WebGPU: Rename WGPUProgrammableStageDescriptor to WGPUComputeState
https://bugs.webkit.org/show_bug.cgi?id=324801
rdar://188063310

Reviewed by Mike Wyrzykowski.

Rename WGPUProgrammableStageDescriptor to WGPUComputeState. This makes
WebGPU.h match the standard webgpu.h for this symbol. Since
WebGPU.h arbitrarily mimics webgpu.h, there is no benefit in deviating.

This is work towards being able to use WebGPU.h in ANGLE/WebGPU that
uses the standard webgpu.h interface.

* Source/WebCore/Modules/WebGPU/Implementation/WebGPUDeviceImpl.cpp:
(WebCore::WebGPU::convertToBacking):
* Source/WebGPU/WebGPU/WebGPU.h:
(WGPUComputeState::constantsSpan const):
(WGPUProgrammableStageDescriptor::constantsSpan const): Deleted.

Canonical link: https://commits.webkit.org/321669@main



To unsubscribe from these emails, change your notification settings at 
https://github.com/WebKit/WebKit/settings/notifications

Reply via email to