Branch: refs/heads/main
  Home:   https://github.com/WebKit/WebKit
  Commit: edfe75292ddbdc9b5692e11f3e0af55cb020c23f
      
https://github.com/WebKit/WebKit/commit/edfe75292ddbdc9b5692e11f3e0af55cb020c23f
  Author: Kiet Ho <[email protected]>
  Date:   2026-10-01 (Thu, 01 Oct 2026)

  Changed paths:
    M Source/WebCore/css/CSSProperties.json
    M Source/WebCore/style/StyleDifference.cpp
    M 
Source/WebCore/style/computed/StyleComputedStyleProperties+SettersCustomInlines.h
    M Source/WebCore/style/computed/data/StyleNonInheritedRareData.cpp
    M Source/WebCore/style/computed/data/StyleNonInheritedRareData.h

  Log Message:
  -----------
  Rename effectiveBlendMode to blendMode
rdar://188891583
https://bugs.webkit.org/show_bug.cgi?id=325925

Reviewed by Tim Nguyen.

This patch renames effectiveBlendMode in NonInheritedRareData to blendMode,
as I'm not sure why the `effective` part is needed.

Refactoring, tested by existing suite.

* Source/WebCore/css/CSSProperties.json:
* Source/WebCore/style/StyleDifference.cpp:
* 
Source/WebCore/style/computed/StyleComputedStyleProperties+SettersCustomInlines.h:
(WebCore::Style::ComputedStyleProperties::setBlendMode):
* Source/WebCore/style/computed/data/StyleNonInheritedRareData.cpp:
(WebCore::Style::NonInheritedRareData::NonInheritedRareData):
(WebCore::Style::NonInheritedRareData::operator== const):
(WebCore::Style::NonInheritedRareData::dumpDifferences const):
* Source/WebCore/style/computed/data/StyleNonInheritedRareData.h:

Canonical link: https://commits.webkit.org/322453@main



To unsubscribe from these emails, change your notification settings at 
https://github.com/WebKit/WebKit/settings/notifications

Reply via email to