Branch: refs/heads/main
  Home:   https://github.com/WebKit/WebKit
  Commit: d14092c05dd568c90ca6a906119c5c9c6587b5be
      
https://github.com/WebKit/WebKit/commit/d14092c05dd568c90ca6a906119c5c9c6587b5be
  Author: Antti Koivisto <[email protected]>
  Date:   2026-10-02 (Fri, 02 Oct 2026)

  Changed paths:
    M Source/WebCore/rendering/RenderBox.cpp
    M Source/WebCore/rendering/RenderBox.h
    M Source/WebCore/style/values/primitives/StylePrimitiveNumericOrKeyword.h
    M Source/WebCore/style/values/sizing/StyleSizing.h

  Log Message:
  -----------
  [css-values-5 calc-size()] Add switchOnKeyword helper
https://bugs.webkit.org/show_bug.cgi?id=326063
rdar://188995632

Reviewed by Alan Baradlay.

Add a helper and use it remove some repeated if()s.

* Source/WebCore/rendering/RenderBox.cpp:
(WebCore::RenderBox::computeIntrinsicKeywordLogicalWidths const):
(WebCore::RenderBox::computeSizingKeywordLogicalWidthUsing const):
(WebCore::RenderBox::computeSizingKeywordLogicalWidthUsingGeneric const):
(WebCore::RenderBox::computeSizingKeywordLogicalContentHeightUsingGeneric 
const):
* Source/WebCore/rendering/RenderBox.h:
* Source/WebCore/style/values/primitives/StylePrimitiveNumericOrKeyword.h:
* Source/WebCore/style/values/sizing/StyleSizing.h:

Add a IsSizingKeyword concept.

Canonical link: https://commits.webkit.org/322497@main



To unsubscribe from these emails, change your notification settings at 
https://github.com/WebKit/WebKit/settings/notifications

Reply via email to