Title: [126917] trunk/Source/WebKit/chromium
Revision
126917
Author
[email protected]
Date
2012-08-28 12:59:52 -0700 (Tue, 28 Aug 2012)

Log Message

[unreviewed] Compile fix: windows compiler expects float but find double.

Need to specify a float literal when initialising the highlight animation duration.

* src/LinkHighlight.cpp:
(WebKit::LinkHighlight::startHighlightAnimation):

Modified Paths

Diff

Modified: trunk/Source/WebKit/chromium/ChangeLog (126916 => 126917)


--- trunk/Source/WebKit/chromium/ChangeLog	2012-08-28 19:55:06 UTC (rev 126916)
+++ trunk/Source/WebKit/chromium/ChangeLog	2012-08-28 19:59:52 UTC (rev 126917)
@@ -1,3 +1,12 @@
+2012-08-28  W. James MacLean  <[email protected]>
+
+        [unreviewed] Compile fix: windows compiler expects float but find double.
+ 
+        Need to specify a float literal when initialising the highlight animation duration.
+ 
+        * src/LinkHighlight.cpp:
+        (WebKit::LinkHighlight::startHighlightAnimation):
+
 2012-08-28  Caio Marcelo de Oliveira Filho  <[email protected]>
 
         Rename first/second to key/value in HashMap iterators

Modified: trunk/Source/WebKit/chromium/src/LinkHighlight.cpp (126916 => 126917)


--- trunk/Source/WebKit/chromium/src/LinkHighlight.cpp	2012-08-28 19:55:06 UTC (rev 126916)
+++ trunk/Source/WebKit/chromium/src/LinkHighlight.cpp	2012-08-28 19:59:52 UTC (rev 126917)
@@ -196,7 +196,7 @@
 {
     const float startOpacity = 1;
     // FIXME: Should duration be configurable?
-    const float duration = 0.1;
+    const float duration = 0.1f;
 
     m_contentLayer->layer()->setOpacity(startOpacity);
 
_______________________________________________
webkit-changes mailing list
[email protected]
http://lists.webkit.org/mailman/listinfo/webkit-changes

Reply via email to