Title: [145347] trunk/Source/WebCore
Revision
145347
Author
[email protected]
Date
2013-03-11 02:40:08 -0700 (Mon, 11 Mar 2013)

Log Message

[Chromium] REGRESSION: Closed Captions button not showing properly
https://bugs.webkit.org/show_bug.cgi?id=109871

Reviewed by Jer Noble.

No new tests - covered by existing tests.

Most of the patch was in the meantime covered by a patch to
https://bugs.webkit.org/show_bug.cgi?id=111109 .
This changes a static Chromium-only function name to be consistent with
parent class function names.

* rendering/RenderMediaControlsChromium.cpp:
(WebCore::paintMediaToggleClosedCaptionsButton):
(WebCore::RenderMediaControlsChromium::paintMediaControlsPart):
Rename paintMediaClosedCaptionsButton to paintMediaToggleClosedCaptionsButton.

Modified Paths

Diff

Modified: trunk/Source/WebCore/ChangeLog (145346 => 145347)


--- trunk/Source/WebCore/ChangeLog	2013-03-11 08:43:22 UTC (rev 145346)
+++ trunk/Source/WebCore/ChangeLog	2013-03-11 09:40:08 UTC (rev 145347)
@@ -1,3 +1,22 @@
+2013-03-11  Silvia Pfeiffer  <[email protected]>
+
+        [Chromium] REGRESSION: Closed Captions button not showing properly
+        https://bugs.webkit.org/show_bug.cgi?id=109871
+
+        Reviewed by Jer Noble.
+
+        No new tests - covered by existing tests.
+
+        Most of the patch was in the meantime covered by a patch to
+        https://bugs.webkit.org/show_bug.cgi?id=111109 .
+        This changes a static Chromium-only function name to be consistent with
+        parent class function names.
+
+        * rendering/RenderMediaControlsChromium.cpp:
+        (WebCore::paintMediaToggleClosedCaptionsButton):
+        (WebCore::RenderMediaControlsChromium::paintMediaControlsPart):
+        Rename paintMediaClosedCaptionsButton to paintMediaToggleClosedCaptionsButton.
+
 2013-03-11  Tim Horton  <[email protected]>
 
         RenderSnapshottedPlugIn paints in PaintPhaseBlockBackground instead of PaintPhaseForeground

Modified: trunk/Source/WebCore/rendering/RenderMediaControlsChromium.cpp (145346 => 145347)


--- trunk/Source/WebCore/rendering/RenderMediaControlsChromium.cpp	2013-03-11 08:43:22 UTC (rev 145346)
+++ trunk/Source/WebCore/rendering/RenderMediaControlsChromium.cpp	2013-03-11 09:40:08 UTC (rev 145347)
@@ -327,7 +327,7 @@
     return paintMediaButton(paintInfo.context, rect, mediaFullscreenButton);
 }
 
-static bool paintMediaClosedCaptionsButton(RenderObject* object, const PaintInfo& paintInfo, const IntRect& rect)
+static bool paintMediaToggleClosedCaptionsButton(RenderObject* object, const PaintInfo& paintInfo, const IntRect& rect)
 {
     HTMLMediaElement* mediaElement = toParentMediaElement(object);
     if (!mediaElement)
@@ -353,7 +353,7 @@
     case MediaPlayButton:
         return paintMediaPlayButton(object, paintInfo, rect);
     case MediaShowClosedCaptionsButton:
-        return paintMediaClosedCaptionsButton(object, paintInfo, rect);
+        return paintMediaToggleClosedCaptionsButton(object, paintInfo, rect);
     case MediaSlider:
         return paintMediaSlider(object, paintInfo, rect);
     case MediaSliderThumb:
_______________________________________________
webkit-changes mailing list
[email protected]
https://lists.webkit.org/mailman/listinfo/webkit-changes

Reply via email to