Title: [145363] trunk/Source/WebCore
Revision
145363
Author
[email protected]
Date
2013-03-11 08:26:17 -0700 (Mon, 11 Mar 2013)

Log Message

[BlackBerry] GraphicsLayer: rename notifySyncRequired to notifyFlushRequired
https://bugs.webkit.org/show_bug.cgi?id=111997

Patch by Alberto Garcia <[email protected]> on 2013-03-11
Reviewed by Rob Buis.

This changed in r130439 but the old name was introduced again by
mistake in r144465.

* platform/graphics/blackberry/GraphicsLayerBlackBerry.h:
(WebCore::GraphicsLayerBlackBerry::notifyFlushRequired):
* platform/graphics/blackberry/LayerWebKitThread.cpp:
(WebCore::LayerWebKitThread::setNeedsCommit):

Modified Paths

Diff

Modified: trunk/Source/WebCore/ChangeLog (145362 => 145363)


--- trunk/Source/WebCore/ChangeLog	2013-03-11 14:43:40 UTC (rev 145362)
+++ trunk/Source/WebCore/ChangeLog	2013-03-11 15:26:17 UTC (rev 145363)
@@ -1,3 +1,18 @@
+2013-03-11  Alberto Garcia  <[email protected]>
+
+        [BlackBerry] GraphicsLayer: rename notifySyncRequired to notifyFlushRequired
+        https://bugs.webkit.org/show_bug.cgi?id=111997
+
+        Reviewed by Rob Buis.
+
+        This changed in r130439 but the old name was introduced again by
+        mistake in r144465.
+
+        * platform/graphics/blackberry/GraphicsLayerBlackBerry.h:
+        (WebCore::GraphicsLayerBlackBerry::notifyFlushRequired):
+        * platform/graphics/blackberry/LayerWebKitThread.cpp:
+        (WebCore::LayerWebKitThread::setNeedsCommit):
+
 2013-03-11  Kent Tamura  <[email protected]>
 
         Inappropriate validation message for required number/date input elements

Modified: trunk/Source/WebCore/platform/graphics/blackberry/GraphicsLayerBlackBerry.h (145362 => 145363)


--- trunk/Source/WebCore/platform/graphics/blackberry/GraphicsLayerBlackBerry.h	2013-03-11 14:43:40 UTC (rev 145362)
+++ trunk/Source/WebCore/platform/graphics/blackberry/GraphicsLayerBlackBerry.h	2013-03-11 15:26:17 UTC (rev 145363)
@@ -113,10 +113,10 @@
     virtual void setDebugBackgroundColor(const Color&);
     virtual void setDebugBorder(const Color&, float borderWidth);
 
-    void notifySyncRequired()
+    void notifyFlushRequired()
     {
         if (m_client)
-            m_client->notifySyncRequired(this);
+            m_client->notifyFlushRequired(this);
     }
 
     void notifyAnimationStarted(double time)

Modified: trunk/Source/WebCore/platform/graphics/blackberry/LayerWebKitThread.cpp (145362 => 145363)


--- trunk/Source/WebCore/platform/graphics/blackberry/LayerWebKitThread.cpp	2013-03-11 14:43:40 UTC (rev 145362)
+++ trunk/Source/WebCore/platform/graphics/blackberry/LayerWebKitThread.cpp	2013-03-11 15:26:17 UTC (rev 145363)
@@ -169,11 +169,11 @@
 
 void LayerWebKitThread::setNeedsCommit()
 {
-    // Call notifySyncRequired(), which in this implementation plumbs through to
+    // Call notifyFlushRequired(), which in this implementation plumbs through to
     // call scheduleRootLayerCommit() on the WebView, which will cause us to commit
     // changes done on the WebKit thread for display on the Compositing thread.
     if (m_owner)
-        m_owner->notifySyncRequired();
+        m_owner->notifyFlushRequired();
 }
 
 void LayerWebKitThread::notifyAnimationsStarted(double time)
_______________________________________________
webkit-changes mailing list
[email protected]
https://lists.webkit.org/mailman/listinfo/webkit-changes

Reply via email to