Title: [163394] trunk/Source
Revision
163394
Author
[email protected]
Date
2014-02-04 11:32:56 -0800 (Tue, 04 Feb 2014)

Log Message

Rename String::getCharacters to String::characters
https://bugs.webkit.org/show_bug.cgi?id=128196

Reviewed by Andreas Kling.

Source/_javascript_Core:

Update for WTF::String changes.

* yarr/YarrParser.h:
(JSC::Yarr::Parser::Parser):

Source/WebCore:

Update for WTF::String changes.

* dom/Document.cpp:
(WebCore::canonicalizedTitle):

Source/WTF:

This means String::characters() will end up calling either characters8() or characters16() which
makes more logical sense. It also frees up the getCharacters name so we can use it for a new function
that will do upconversion.

* wtf/text/StringBuilder.cpp:
(WTF::StringBuilder::appendUninitializedSlow):
* wtf/text/WTFString.h:
(WTF::String::characters<LChar>):
(WTF::String::characters<UChar>):

Modified Paths

Diff

Modified: trunk/Source/_javascript_Core/ChangeLog (163393 => 163394)


--- trunk/Source/_javascript_Core/ChangeLog	2014-02-04 19:22:15 UTC (rev 163393)
+++ trunk/Source/_javascript_Core/ChangeLog	2014-02-04 19:32:56 UTC (rev 163394)
@@ -1,3 +1,15 @@
+2014-02-04  Anders Carlsson  <[email protected]>
+
+        Rename String::getCharacters to String::characters
+        https://bugs.webkit.org/show_bug.cgi?id=128196
+
+        Reviewed by Andreas Kling.
+
+        Update for WTF::String changes.
+
+        * yarr/YarrParser.h:
+        (JSC::Yarr::Parser::Parser):
+
 2014-02-04  Mark Hahnenberg  <[email protected]>
 
         ASSERT in speculateMachineInt on 32-bit platforms

Modified: trunk/Source/_javascript_Core/yarr/YarrParser.h (163393 => 163394)


--- trunk/Source/_javascript_Core/yarr/YarrParser.h	2014-02-04 19:22:15 UTC (rev 163393)
+++ trunk/Source/_javascript_Core/yarr/YarrParser.h	2014-02-04 19:32:56 UTC (rev 163394)
@@ -232,7 +232,7 @@
         : m_delegate(delegate)
         , m_backReferenceLimit(backReferenceLimit)
         , m_err(NoError)
-        , m_data(pattern.getCharacters<CharType>())
+        , m_data(pattern.characters<CharType>())
         , m_size(pattern.length())
         , m_index(0)
         , m_parenthesesNestingDepth(0)

Modified: trunk/Source/WTF/ChangeLog (163393 => 163394)


--- trunk/Source/WTF/ChangeLog	2014-02-04 19:22:15 UTC (rev 163393)
+++ trunk/Source/WTF/ChangeLog	2014-02-04 19:32:56 UTC (rev 163394)
@@ -1,3 +1,20 @@
+2014-02-04  Anders Carlsson  <[email protected]>
+
+        Rename String::getCharacters to String::characters
+        https://bugs.webkit.org/show_bug.cgi?id=128196
+
+        Reviewed by Andreas Kling.
+
+        This means String::characters() will end up calling either characters8() or characters16() which
+        makes more logical sense. It also frees up the getCharacters name so we can use it for a new function
+        that will do upconversion.
+        
+        * wtf/text/StringBuilder.cpp:
+        (WTF::StringBuilder::appendUninitializedSlow):
+        * wtf/text/WTFString.h:
+        (WTF::String::characters<LChar>):
+        (WTF::String::characters<UChar>):
+
 2014-02-03  Anders Carlsson  <[email protected]>
 
         Fix Windows build.

Modified: trunk/Source/WTF/wtf/text/StringBuilder.cpp (163393 => 163394)


--- trunk/Source/WTF/wtf/text/StringBuilder.cpp	2014-02-04 19:22:15 UTC (rev 163393)
+++ trunk/Source/WTF/wtf/text/StringBuilder.cpp	2014-02-04 19:32:56 UTC (rev 163394)
@@ -233,7 +233,7 @@
         reallocateBuffer<CharType>(expandedCapacity(capacity(), requiredLength));
     } else {
         ASSERT(m_string.length() == m_length);
-        allocateBuffer(m_length ? m_string.getCharacters<CharType>() : 0, expandedCapacity(capacity(), requiredLength));
+        allocateBuffer(m_length ? m_string.characters<CharType>() : 0, expandedCapacity(capacity(), requiredLength));
     }
     
     CharType* result = getBufferCharacters<CharType>() + m_length;

Modified: trunk/Source/WTF/wtf/text/WTFString.h (163393 => 163394)


--- trunk/Source/WTF/wtf/text/WTFString.h	2014-02-04 19:22:15 UTC (rev 163393)
+++ trunk/Source/WTF/wtf/text/WTFString.h	2014-02-04 19:32:56 UTC (rev 163394)
@@ -182,9 +182,9 @@
 
     // Return characters8() or characters16() depending on CharacterType.
     template <typename CharacterType>
-    inline const CharacterType* getCharacters() const;
+    inline const CharacterType* characters() const;
 
-    // Like getCharacters() and upconvert if CharacterType is UChar on a 8bit string.
+    // Like characters() and upconvert if CharacterType is UChar on a 8bit string.
     template <typename CharacterType>
     inline const CharacterType* getCharactersWithUpconvert() const;
 
@@ -518,14 +518,14 @@
 }
 
 template<>
-inline const LChar* String::getCharacters<LChar>() const
+inline const LChar* String::characters<LChar>() const
 {
     ASSERT(is8Bit());
     return characters8();
 }
 
 template<>
-inline const UChar* String::getCharacters<UChar>() const
+inline const UChar* String::characters<UChar>() const
 {
     ASSERT(!is8Bit());
     return characters16();

Modified: trunk/Source/WebCore/ChangeLog (163393 => 163394)


--- trunk/Source/WebCore/ChangeLog	2014-02-04 19:22:15 UTC (rev 163393)
+++ trunk/Source/WebCore/ChangeLog	2014-02-04 19:32:56 UTC (rev 163394)
@@ -1,3 +1,15 @@
+2014-02-04  Anders Carlsson  <[email protected]>
+
+        Rename String::getCharacters to String::characters
+        https://bugs.webkit.org/show_bug.cgi?id=128196
+
+        Reviewed by Andreas Kling.
+
+        Update for WTF::String changes.
+
+        * dom/Document.cpp:
+        (WebCore::canonicalizedTitle):
+
 2014-02-04  Eric Carlson  <[email protected]>
 
         Fix Release build after r163390.

Modified: trunk/Source/WebCore/dom/Document.cpp (163393 => 163394)


--- trunk/Source/WebCore/dom/Document.cpp	2014-02-04 19:22:15 UTC (rev 163393)
+++ trunk/Source/WebCore/dom/Document.cpp	2014-02-04 19:32:56 UTC (rev 163394)
@@ -1402,7 +1402,7 @@
 static inline StringWithDirection canonicalizedTitle(Document* document, const StringWithDirection& titleWithDirection)
 {
     const String& title = titleWithDirection.string();
-    const CharacterType* characters = title.getCharacters<CharacterType>();
+    const CharacterType* characters = title.characters<CharacterType>();
     unsigned length = title.length();
     unsigned i;
 
_______________________________________________
webkit-changes mailing list
[email protected]
https://lists.webkit.org/mailman/listinfo/webkit-changes

Reply via email to