Title: [188740] trunk/Source/WebKit2
Revision
188740
Author
[email protected]
Date
2015-08-20 19:35:35 -0700 (Thu, 20 Aug 2015)

Log Message

GTK build fix after r188693.

* UIProcess/API/gtk/PageClientImpl.h:
Delete mediaDocumentNaturalSizeChanged which could be renamed to imageOrMediaDocumentSizeChanged, 
but there's no reason to have an empty function overriding another virtual function that is also empty.

Modified Paths

Diff

Modified: trunk/Source/WebKit2/ChangeLog (188739 => 188740)


--- trunk/Source/WebKit2/ChangeLog	2015-08-21 02:34:34 UTC (rev 188739)
+++ trunk/Source/WebKit2/ChangeLog	2015-08-21 02:35:35 UTC (rev 188740)
@@ -1,3 +1,11 @@
+2015-08-20  Alex Christensen  <[email protected]>
+
+        GTK build fix after r188693.
+
+        * UIProcess/API/gtk/PageClientImpl.h:
+        Delete mediaDocumentNaturalSizeChanged which could be renamed to imageOrMediaDocumentSizeChanged, 
+        but there's no reason to have an empty function overriding another virtual function that is also empty.
+
 2015-08-20  Joonghun Park  <[email protected]>
 
         [EFL] Fix build error since r188693

Modified: trunk/Source/WebKit2/UIProcess/API/gtk/PageClientImpl.h (188739 => 188740)


--- trunk/Source/WebKit2/UIProcess/API/gtk/PageClientImpl.h	2015-08-21 02:34:34 UTC (rev 188739)
+++ trunk/Source/WebKit2/UIProcess/API/gtk/PageClientImpl.h	2015-08-21 02:35:35 UTC (rev 188740)
@@ -132,10 +132,6 @@
 
     virtual void didChangeBackgroundColor() override;
 
-#if ENABLE(VIDEO)
-    virtual void mediaDocumentNaturalSizeChanged(const WebCore::IntSize&) override { }
-#endif
-
     virtual void refView() override;
     virtual void derefView() override;
 
_______________________________________________
webkit-changes mailing list
[email protected]
https://lists.webkit.org/mailman/listinfo/webkit-changes

Reply via email to