>#include <domain/osextensions/platform_paths.hrh>
it is #ifdef-ed out in the bld.inf. Carbide does not manage #ifdefs in
the build files properly.

Zalan.

On Wed, Jul 16, 2008 at 12:41 PM, Jack Wootton <[EMAIL PROTECTED]> wrote:
> To add, the following two files are displaying errors in Carbide:
>
> S60\JavaScriptCore\group\bld.inf
> S60\WebKit\group\bld.inf
>
> JavaScriptCore bld.inf both have a problem with the following line:
>
> #include <domain/osextensions/platform_paths.hrh>
>
> Presumably it can't find the file.
>
>
>
> On Wed, Jul 16, 2008 at 5:11 PM, Jack Wootton <[EMAIL PROTECTED]> wrote:
>> Hi all,
>>
>> Having successfully built S60 WebKit on the command line (using an
>> older version (21772 )), I decided to try building it in Carbide. I
>> get the following errors:
>>
>> /********************************** Start Errors
>> **********************************/
>>
>> In file included from .\BLD.INF:50:
>> .\.\JavaScriptCore\group\bld.inf:28:
>> domain/osextensions/platform_paths.hrh: No such file or directory
>>
>> In file included from .\BLD.INF:52:
>> .\.\WEBKIT\group\bld.inf:42: domain/osextensions/platform_paths.hrh:
>> No such file or directory
>> BLDMAKE ERROR: ERROR: cpp.exe returned non-zero exit status (8448)
>>        cpp.EXE -undef -nostdinc -+  -I ..\epoc32\include -I . -I .\  -I
>> "..\epoc32\include\variant" -include
>> ..\epoc32\include\variant\Symbian_OS_v9.1.hrh ".\BLD.INF"
>>
>> /********************************** End Errors
>> **********************************/
>>
>> The build target inside Carbide was set to Emulator Debug (WINSCW).
>>
>> Can anyone help?
>>
>> --
>> Regards
>> Jack
>>
>
>
>
> --
> Regards
> Jack
> _______________________________________________
> webkit-dev mailing list
> webkit-dev@lists.webkit.org
> http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev
>
_______________________________________________
webkit-dev mailing list
webkit-dev@lists.webkit.org
http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev

Reply via email to