No substantive comment, but a small style comment.
On May 21, 2009, at 4:20 PM, Drew Wilson wrote:
// Static factory method for getting the correct repository
implementation for a given browser
static public SharedWorkerRepository* getRepository();
Generally WebKit does not use the verb "get" to name functions that
simply return something. Instead for those we simply use a noun.
If there is some real action involved, then we would want to use a
verb, but not "get". For example, if the function always creates
something we can use the word create.
Sadly we have not yet found a good verb for the common "get or create"
idiom.
-- Darin
_______________________________________________
webkit-dev mailing list
webkit-dev@lists.webkit.org
http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev