(https://bugs.webkit.org/show_bug.cgi?id=32250 is the relevant bug)

Summary: ClassNames used to be used only for class names, but its behavior
meets the requirements for HTML5's strings of space separated tokens.  If
folks are ok with it, I'd like to rename ClassNames to something more
generic so that it is more appropriate to use it for HTML5 features (the
only current html5-flavored usage I know of is the one I introduced in
HTMLAnchorElement<http://trac.webkit.org/browser/trunk/WebCore/html/HTMLAnchorElement.cpp?annotate=blame&rev=51703#L343>
).

I was thinking of renaming it to SpaceSplitString, or AtomicStringList (it's
previous name), but I'm not hung up on any particular name.

Any thoughts or objections?
~Nate
_______________________________________________
webkit-dev mailing list
webkit-dev@lists.webkit.org
http://lists.webkit.org/mailman/listinfo.cgi/webkit-dev

Reply via email to