On Mon, Feb 18, 2013 at 6:18 PM, Darin Adler <da...@apple.com> wrote:

> On Feb 18, 2013, at 6:17 PM, Ryosuke Niwa <rn...@webkit.org> wrote:
>
> > See https://bugs.webkit.org/show_bug.cgi?id=110146 where we're going to
> rename the class, member functions and variables.
>
> Thanks. Good discussion there.
>
> What about my other question? Why is this a class instead of a function?
>

I had the same question when I found this class today but when I tried to
turn it into a function, I realized that each caller of this function now
needs to maintain two variables instead of one. Since those two variables
(node and distributedNode) need to be in a consistent state, I've thought
of creating a state object but then it seemed silly to create a state
object only and a free function. It's much more natural for it be just a
"walker" class.

Having said that, I don't like seemingly excessive use of design patterns
prevalent in some of the code we're adding, particularly, for shadow DOM.

- R. Niwa
_______________________________________________
webkit-dev mailing list
webkit-dev@lists.webkit.org
https://lists.webkit.org/mailman/listinfo/webkit-dev

Reply via email to