I think we should put it where we currently have the header guard. I think the pragma is easier to understand than a #ifndef/#define.
- Anders > On Mar 9, 2016, at 5:33 PM, Brian Burg <bb...@apple.com> wrote: > > Cool! It sounds like something good for new headers and drive-by cleanups, to > start. > To clarify, it would always go after the license block? Is the pragma name > stable and understandable enough to paste everywhere? > > -Brian > >> On Mar 9, 2016, at 17:27, Anders Carlsson <ander...@apple.com> wrote: >> >> Hi floks, >> >> Currently we use >> >> #ifndef Header_h >> #define Header_h >> >> … >> >> #endif >> >> I propose that we instead start using >> >> #pragma once >> >> which does the same thing. It can be faster on some compilers, is less error >> prone and is one line instead of three! All compilers we use support #pragma >> once. >> >> Thoughts? >> - Anders >> >> _______________________________________________ >> webkit-dev mailing list >> firstname.lastname@example.org >> https://lists.webkit.org/mailman/listinfo/webkit-dev > _______________________________________________ webkit-dev mailing list email@example.com https://lists.webkit.org/mailman/listinfo/webkit-dev