Hi all,

During the WebKit Contributors Meeting, Simon Fraser suggested that I
should verify some of the my patches using WK1. Hence I did some
experiments (again):

* When I run run-webkit-tests, whatever the value specified via
--platform, the selected expectation is always a "wk2" file and the code
executed is from WebKit (i.e. WK2 == non-legacy).

* I wrote a dummy iOS app using the deprecated UIWebView [1] and tried
to launch it with Tools/Scripts/run-webkit-app --ios-simulator
/path/to/WebKitLegacyApp.app ; that seems to be working (code from
WebKitLegacy is indeed executed). Also, page is loaded and properly
rendered at startup so I can somewhat test it. However, the app does not
reply to user interaction so it's difficult to do manual testing (not to
mention features like the Find UI are not available).

Also, I have not checked but IIRC the EWS bots actually only run iOS/WK2
tests, right?

Any idea/suggestion regarding how one could test iOS/WK1?

PS: I'm using the public Xcode SDK. In particular I only have access to
the simulator.

[1] https://github.com/fred-wang/WebKitLegacyApp

-- 
Frédéric Wang - frederic-wang.fr


_______________________________________________
webkit-dev mailing list
webkit-dev@lists.webkit.org
https://lists.webkit.org/mailman/listinfo/webkit-dev

Reply via email to