Hello
Sorry i do not know english so i am using google translator.
I have a problem:
Installation on OrangePi PC system of 
Armbian_5.30_Orangepipc_Ubuntu_xenial_default_3.4.113
By the command:
Sudo apt-get install weewx
The weather station is ULTIMETER 2100.
Data from the station sent rs232 / ethernet converter.
Port created with the command:

*Orangepi @ orangepipc: ~ $ sudo socat PTY, link = / dev / netcom0, raw, 
echo = 0, waitslave TCP4: 192.168.0.118: 23*
 
*In the / dev / directory there is a file @ netcom0 on which is the data 
when you connect to the terminal program:*

*Welcome to minicom 2.7*

*OPTIONS: I18n*
*Compiled on Feb 7 2016, 14:00:34.*
*Port / dev / netcom0, 14:01:20*
                                                                            
 
*Press CTRL-A Z for help on special keys*
                                                                            
                              
*YY? YY !! 009100EF02F2070A275202CA -------- 00DA025F00000085*
*009100EF02F2070A275202CA 00DA025F00000085 -------- !!*
*008F00F902F2070A275202CA 00DA025F00000085 -------- !!*
*008F00F902F2070A275202CA 00DA025F00000085 -------- !!*
*008F00F902F2070A275202CA 00DA025F00000085 -------- !!*
*008D00EE02F2070A275202CA 00DA025F00000085 -------- !!*
*008D00EE02F2070A275202CA 00DA025F00000085 -------- !!*
*009900F002F2070A275202CA 00DA025F00000085 -------- !!*

It looks like the station is sending weather data.
Ultimeter is set to "data loger mode"

Sataus looks like this:

*Orangepi @ orangepipc: ~ $ sudo /etc/init.d/weewx status*
*‚óŹ weewx.service - LSB: weewx weather system*
*   Loaded: loaded (/etc/init.d/weewx; bad; vendor preset: enabled)*
*   Active: active (exited) since Sun 2017-08-06 14:01:50 UTC; 36min ago*
*     Docs: man: systemd-sysv-generator (8)*
*  Process: 4153 ExecStop = / etc / init.d / weewx stop (code = exited, 
status = 0 / SUCCESS)*
*  Process: 4193 ExecStart = / etc / init.d / weewx start (code = exited, 
status = 0 / SUCCESS)*

*Aug 06 14:01:50 orangepipc weewx [4207]: engine: Initializing engine*
*Aug 06 14:01:50 orangepipc weewx [4207]: engine: Loading station type 
Ultimeter (weewx.drivers.ultimeter)*
*Aug 06 14:01:50 orangepipc weewx [4193]: ... done.*
*Aug 06 14:01:50 orangepipc systemd [1]: Started LSB: weewx weather system.*
*Aug 06 14:01:50 orangepipc weewx [4207]: ultimeter: driver version is 0.18*
*Aug 06 14:01:50 orangepipc weewx [4207]: ultimeter: using serial port / 
dev / netcom0*
*Aug 06 14:01:50 orangepipc weewx [4207]: ultimeter: open serial port / dev 
/ netcom0*
*Aug 06 14:01:50 orangepipc weewx [4207]: import of driver failed: [Errno 
22] Invalid argument (<type 'exceptions.IOError'>)*
*Aug 06 14:01:50 orangepipc weewx [4207]: engine: Unable to load driver: 
[Errno 22] Invalid argument*
*Aug 06 14:01:50 orangepipc weewx [4207]: **** Exiting ...*
*orangepi orangepipc @: ~ $*

After restart weewx:

*Orangepi @ orangepipc: ~ $ sudo /etc/init.d/weewx stop*
*[Ok] stopping weewx (via systemctl): weewx.service.*
*Orangepi @ orangepipc: ~ $ sudo /etc/init.d/weewx restart*
*[Ok] Restarting weewx (via systemctl): weewx.service.*
*Orangepi @ orangepipc: ~ $ sudo tail -f / var / log / syslog*
*Aug 6 15:02:23 localhost weewx [4585]: engine: Initializing engine*
*Aug 6 15:02:23 localhost weewx [4585]: engine: Loading station type 
Ultimeter (weewx.drivers.ultimeter)*
*Aug 6 15:02:23 localhost weewx [4571]: ... done.*
*Aug 6 15:02:23 localhost systemd [1]: Started LSB: weewx weather system.*
*Aug 6 15:02:23 localhost weewx [4585]: ultimeter: driver version is 0.18*
*Aug 6 15:02:23 localhost weewx [4585]: ultimeter: using serial port / dev 
/ netcom0*
*Aug 6 15:02:23 localhost weewx [4585]: ultimeter: open serial port / dev / 
netcom0*
*Aug 6 15:02:23 localhost weewx [4585]: import of driver failed: [Errno 22] 
Invalid argument (<type 'exceptions.IOError'>)*
*Aug 6 15:02:23 localhost weewx [4585]: engine: Unable to load driver: 
[Errno 22] Invalid argument*
*Aug 6 15:02:23 localhost weewx [4585]: **** Exiting ...*

I set debug = 1 in the configuration file in weewx.conf

I will add that I have already reinstalled the weewx breed before removing 
it, including the configuration files.
I also installed a pyserial package.
I also switched modes COMPLETE RECORD MODE, DATA LOGGER MODE, MODEM MODE.
Currently set to Data Logger mode.


Please help.

-- 
You received this message because you are subscribed to the Google Groups 
"weewx-user" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to weewx-user+unsubscr...@googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Reply via email to