I replaced the serial data logger with a new usb data logger and am no 
longer getting the CRC16 errors and the web pages are being updated 
successfully, so the resolution to this `interesting' problem was a damaged 
data logger module.

Please accept my gratitude to this community, particularly Thomas, and Gary 
for hanging in there with me to help solve this problem. 

ted


On Monday, January 13, 2020 at 12:03:14 PM UTC-7, Ted Frohling wrote:
>
> I will list this forum know what the outcome is.  The data logger is 
> scheduled for delivery tomorrow.
>
> Thanks all,
>
> ted
>
>
> On Monday, January 13, 2020 at 6:38:49 AM UTC-7, Thomas Keffer wrote:
>>
>> I suspect you're right. Sounds like a bad logger. It's rare, but not 
>> unprecedented.
>>
>> On Sun, Jan 12, 2020 at 9:05 PM Ted Frohling <ted.f...@gmail.com> wrote:
>>
>>> I have a single ISS, single console and wired envoy.  That is, there is 
>>> a cable from the ISS to the envoy.  The data logger inserted in the envoy 
>>> is connected to the Pi via a serial cable.  The console is listening to the 
>>> ISS wirelessly.  I assumed, incorrectly, that the ISS was listening to the 
>>> envoy since the envoy also has an antenna.  I took the logger out of the 
>>> envoy with all the power supplies connected, waited around 30 seconds, and 
>>> plugged it back in to the Envoy, closed the case up and inserted the 
>>> batteries, and got a beep, then about two minutes later, plugged the Envoy 
>>> into the DC wall transformer.   Restarted the weewx software normally (in 
>>> daemon mode). No pages got updated and got CRC16 errors, so restarted weewx 
>>> in software mode, and ordered a new data logger, as I'm pretty sure it's 
>>> the problem.  If not I have a spare...
>>>
>>> Sorry for the confusion.
>>>
>>> ted
>>>
>>>
>>> On Sunday, January 12, 2020 at 5:18:05 AM UTC-7, Thomas Keffer wrote:
>>>>
>>>> Ted, it's not clear what you are doing, nor what setup you have. Slow 
>>>> down and describe your setup carefully.
>>>>
>>>> Do you have a single ISS (the gadget with the wind vane and rain 
>>>> bucket), a single console, and a single Envoy? Which ones are wired to the 
>>>> ISS? You say the Envoy has a wired connection to the ISS. What about the 
>>>> console?
>>>>
>>>> Just to be clear: there is no connection between consoles and Envoys. 
>>>> They listen to the ISS independently, either through a wire, or 
>>>> wirelessly, 
>>>> never to each other.
>>>>
>>>> Finally, you said you removed the logger from the Envoy, but you didn't 
>>>> say whether you put it back in.
>>>>
>>>> -tk
>>>>
>>>> On Sat, Jan 11, 2020 at 4:04 PM Ted Frohling <ted.f...@gmail.com> 
>>>> wrote:
>>>>
>>>>> I removed the data logger from the Envoy and am now getting:
>>>>>
>>>>> Jan 11 17:01:32 weewx weewx[23496]: vantage: Retrieving 513 page(s); 
>>>>> starting index= 3
>>>>> Jan 11 17:01:36 weewx weewx[23496]: vantage: get_data_with_crc16; try 
>>>>> #1 failed: Expected to read 267 chars; got 191 inst
>>>>> ead
>>>>> Jan 11 17:01:36 weewx weewx[23496]: vantage: Timeout in 
>>>>> get_data_with_crc16
>>>>> Jan 11 17:01:36 weewx weewx[23496]: vantage: Getting archive packets 
>>>>> since 2020-01-11 16:40:00 MST (1578786000)
>>>>> Jan 11 17:01:40 weewx weewx[23496]: vantage: Retry  #0 failed
>>>>>
>>>>> I would assume this indicates either a communications problem or very 
>>>>> corrupted memory in the logger.  With the other problems, I suspect bad 
>>>>> memory.  Am I right?
>>>>>
>>>>> ted
>>>>>
>>>>> On Saturday, January 11, 2020 at 4:39:29 PM UTC-7, Ted Frohling wrote:
>>>>>>
>>>>>> Missed he reference to taking the logger out and reseating.  Will do 
>>>>>> that.  The console seems to be working well.  The system is a wired 
>>>>>> system 
>>>>>> that connects to the envoy.  I'm assuming the console receives it's data 
>>>>>> from the envoy via radio.
>>>>>>
>>>>>> ted
>>>>>>
>>>>>>
>>>>>> On Saturday, January 11, 2020 at 4:20:28 AM UTC-7, Thomas Keffer 
>>>>>> wrote:
>>>>>>>
>>>>>>> Did you try reseating the logger?
>>>>>>>
>>>>>>> On Fri, Jan 10, 2020 at 6:36 PM Ted Frohling <ted.f...@gmail.com> 
>>>>>>> wrote:
>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>> On Friday, January 10, 2020 at 6:09:38 PM UTC-7, Ted Frohling wrote:
>>>>>>>>>
>>>>>>>>>
>>>>>>>>>
>>>>>>>>> On Friday, January 10, 2020 at 3:41:10 PM UTC-7, gjr80 wrote:
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>> On Saturday, 11 January 2020 08:15:14 UTC+10, Ted Frohling wrote:
>>>>>>>>>>>
>>>>>>>>>>> Reset the Vantage Pro 2 console and the Weather Envoy for good 
>>>>>>>>>>> measure.  Dumped the database and cleared the memory. Still have 
>>>>>>>>>>> the 
>>>>>>>>>>> problem. The Vantage Pro 2 console is old, and the firmware is 
>>>>>>>>>>> stuck at 
>>>>>>>>>>> 1.90.  Wondering if I should pitch it and get a new console.  
>>>>>>>>>>>
>>>>>>>>>>  
>>>>>>>>>> No need for anything drastic like that. My console is v1.90 and 
>>>>>>>>>> works fine. I don't have an envoy though I don't believe that 
>>>>>>>>>> changes the 
>>>>>>>>>> process for clearing the station memory. Just checking the obvious, 
>>>>>>>>>> but you 
>>>>>>>>>> did stop WeeWX before running wee_device to clear the station 
>>>>>>>>>> memory? Were there any errors returns anywhere during the process?
>>>>>>>>>>
>>>>>>>>>
>>>>>>>>> No errors for either the dump or the clear command. However after 
>>>>>>>>> doing the dump, followed by the clear, and restarting weewx, waiting, 
>>>>>>>>> no 
>>>>>>>>> records are being put into the database. 
>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>> Wondering if the following log messages are indicitive of the 
>>>>>>>>>>> problem:
>>>>>>>>>>>
>>>>>>>>>>> weewx weewx[16819]: cheetahgenerator: Skipping template 
>>>>>>>>>>> wind.html.tmpl: cannot find start time
>>>>>>>>>>> Jan 10 15:10:26 weewx weewx[16819]: cheetahgenerator: Skipping 
>>>>>>>>>>> template barometer.html.tmpl: cannot find start time
>>>>>>>>>>> Jan 10 15:10:26 weewx weewx[16819]: cheetahgenerator: Skipping 
>>>>>>>>>>> template index.html.tmpl: cannot find start time
>>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>>> These are indicative of there being no data in your database. 
>>>>>>>>>> Since you purged and reinstalled earlier your database will have 
>>>>>>>>>> been 
>>>>>>>>>> cleared and since WeeWX cannot get archvie records from the station 
>>>>>>>>>> no 
>>>>>>>>>> archive records are being saved to archive. Once we get archive 
>>>>>>>>>> records 
>>>>>>>>>> those errors will disappear. You could run with record_generation 
>>>>>>>>>> =  software but that is only putting a bandaid on the problem 
>>>>>>>>>> not fixing it.
>>>>>>>>>>
>>>>>>>>>>
>>>>>>>>> I'll try that and see if I can get that working.  thanks.
>>>>>>>>>
>>>>>>>>
>>>>>>>> Setting  record_generation =  software allowed weewx to start 
>>>>>>>> updating the database and web pages are being generated.  Which is 
>>>>>>>> good 
>>>>>>>> news, but as you say a bandaid.
>>>>>>>>
>>>>>>>>
>>>>>>>>
>>>>>>>>> ted
>>>>>>>>>
>>>>>>>>> Tom may have more advice.
>>>>>>>>>>
>>>>>>>>>> Gary
>>>>>>>>>>
>>>>>>>>>> -- 
>>>>>>>> You received this message because you are subscribed to the Google 
>>>>>>>> Groups "weewx-user" group.
>>>>>>>> To unsubscribe from this group and stop receiving emails from it, 
>>>>>>>> send an email to weewx...@googlegroups.com.
>>>>>>>> To view this discussion on the web visit 
>>>>>>>> https://groups.google.com/d/msgid/weewx-user/be6b96b0-ba79-4c0e-a8c9-be6394d312dc%40googlegroups.com
>>>>>>>>  
>>>>>>>> <https://groups.google.com/d/msgid/weewx-user/be6b96b0-ba79-4c0e-a8c9-be6394d312dc%40googlegroups.com?utm_medium=email&utm_source=footer>
>>>>>>>> .
>>>>>>>>
>>>>>>> -- 
>>>>> You received this message because you are subscribed to the Google 
>>>>> Groups "weewx-user" group.
>>>>> To unsubscribe from this group and stop receiving emails from it, send 
>>>>> an email to weewx...@googlegroups.com.
>>>>> To view this discussion on the web visit 
>>>>> https://groups.google.com/d/msgid/weewx-user/ed1204c0-65f8-44ee-bf9a-9f812b7cbab1%40googlegroups.com
>>>>>  
>>>>> <https://groups.google.com/d/msgid/weewx-user/ed1204c0-65f8-44ee-bf9a-9f812b7cbab1%40googlegroups.com?utm_medium=email&utm_source=footer>
>>>>> .
>>>>>
>>>> -- 
>>> You received this message because you are subscribed to the Google 
>>> Groups "weewx-user" group.
>>> To unsubscribe from this group and stop receiving emails from it, send 
>>> an email to weewx...@googlegroups.com.
>>> To view this discussion on the web visit 
>>> https://groups.google.com/d/msgid/weewx-user/6a3c555f-7339-4def-b654-b6ad7ce3f9d9%40googlegroups.com
>>>  
>>> <https://groups.google.com/d/msgid/weewx-user/6a3c555f-7339-4def-b654-b6ad7ce3f9d9%40googlegroups.com?utm_medium=email&utm_source=footer>
>>> .
>>>
>>

-- 
You received this message because you are subscribed to the Google Groups 
"weewx-user" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to weewx-user+unsubscr...@googlegroups.com.
To view this discussion on the web visit 
https://groups.google.com/d/msgid/weewx-user/18176dc1-e143-4df1-8c77-f495f326add6%40googlegroups.com.

Reply via email to