On Wed, Jun 06, 2001 at 02:09:12PM -0400, Edward J. Sabol wrote:
> Hmmmm. I've tried connecting to various sites using https without success.
> I've tried this on both IRIX 6.5.2 and Digital Unix 4.0d.
> When I installed OpenSSL 0.9.6a using the default configure options, it
> didn't make any shared libraries, but I have libssl.a and libcrypto.a
> installed, and wget's configure process does find them. (Do I need to install
> the shared libraries?)
> For example, I can connect to https://www.apache-ssl.org/ in Netscape just
> fine, but here's what happens when I try with wget 1.7:
> [... debug output removed ...]

Not surprising. Neither IRIX 6.5 nor Tru64 UNIX 4.0D have /dev/random.
So, you need either EGD/PRNGD to provide a substitute for your missing
/dev/random. And, the *client* software has to be configured to
support this. So, if wget doesn't call RAND_egd() from OpenSSL, there
is *nothing* you can do. And, from a quick perusal of wget 1.7, it
doesn't. So, 1.7 is useless for https:// on any system without

Note that we have added such support to other programs and will
hopefully get time soon to do it to wget. cURL already has support for
EGD/PRNGD so we're just going to steal their solution.

albert chin ([EMAIL PROTECTED])

Reply via email to