what about alert(xxx.fillStyle.toUppercase()) ?
On 5/10/07, Nicholas Shanks <[EMAIL PROTECTED]> wrote:
On 10 May 2007, at 08:45, Anne van Kesteren wrote:
> On Thu, 10 May 2007 09:02:52 +0200, Nicholas Shanks
> <[EMAIL PROTECTED]> wrote:
>> Would it not make more sense to fix the UAs.
>> lower-case hex is horrible to read.
>
> Feel free to convince the Microsoft Internet Explorer team. Then
> again, it's not like you'd actually read the return value
> of .fillStyle and .strokeStyle yourself anyway...
I assume one would use these getters primarily when debugging a
website during its development, and as such they would be read by
human eyes, and readability is quite important in the case of
debugging. It is easy to scan over DECA67 but deca67 might appear
more like a variable name, distracting the developer, if only
momentarily.
- Nicholas.