On Fri, 26 Feb 2010 23:28:12 +0100, Maciej Stachowiak <[email protected]> wrote:
On Feb 26, 2010, at 11:37 AM, Michael Nordman wrote:
Sure, but a better name could help a bit. For example, this produces
a 'shared' object:

document.getElementById("foo")

while this creates a new one:

myFormElement.getFormData()

It might be ok, but it is a bit inconsistent.

Why not:
formData = new FormData();
formData = new FormData(myFormElement);

ah... +1 the ctor

Indeed, constructor syntax makes it very clear that you are getting a
new object. I like.

I could add this to XMLHttpRequest Level 2.


--
Anne van Kesteren
http://annevankesteren.nl/

Reply via email to