If we're going to choose a name that abstracts the implementation details (and rightly so), why not just go with `navigator.concurrency`?
Sincerely, James Greene Sent from my [smart?]phone On May 4, 2014 8:50 AM, "Adam Barth" <w...@adambarth.com> wrote: > On Sun, May 4, 2014 at 12:13 AM, Tobie Langel <tobie.lan...@gmail.com > >wrote: > > > On May 4, 2014, at 7:45, Rik Cabanier <caban...@gmail.com> wrote: > > > On Sat, May 3, 2014 at 10:32 PM, Eli Grey <m...@eligrey.com> wrote: > > > > > >> The proposal specifically states using logical cores, which handles > > >> all of the CPUs you mentioned properly. > > >> > > >> Intel CPUs with hyperthreading enabled report logical cores as double > > >> the hardware cores. Depending on the version and configuration of the > > >> Samsung Exynos Octa big.LITTLE CPUs, you will get either 4 logical > > >> cores (only one cluster can run at a time) or 8 logical cores > > >> (big.LITTLE MP, available in Exynos 5420 or later only). > > >> > > > > > > Great! > > > Make sure this is captured when it is put in a specification. > > > Otherwise the subtlety between an actual and a logical core might get > > lost. > > > > Shouldn't this also be captured in the API's name? > > > > Maybe navigator.hardwareConcurrency as a nod to the C++11 name? > > Adam >